PC hangs on boot after running backup

Ran backup disk 3 to disk 4. After BU completes, pc gets hung on next boot. Hang s at QNX Loader
Boot partition 1 and a flashing cursor. I then boot off a floppy, and mount both drives. Then able to navigate to root directory for 3: and 4:, but can’t run any commands. Ran fdisk and 3: is marked as boot.
Any thoughts?

Let me start at the end. Having booted off of a floppy, the search order is “1”, so the OS is not going to look for commands anywhere but the floppy. To fix this:

search 3 4 1

You can leave off the 1 if this works.

You can also specify a command directly, e.g.

$ 3:/cmds/ed

You didn’t say how you did the backup, but there’s no obvious reason why this would prevent the system from booting unless you did something wrong. You probably need to fix the boot problem and see if it comes back.

Get back to you tonight M. Thank you. By the way, where are you located? We are in Conn.

You are correct, the problem was not backup. Thanks

I’m in San Francisco. Did the search command allow you to run commands off the HD? If so, you might just need to repair the boot. I can dig up the commands you would need to do this if you want.

Yes search works. New problem. Trying to remove a directory. Released all files except it won’t allow the Bitmap to be released. How do I release the bitmap? thx


The bitmap is not a diretory. The bitmap file is part of the file system. Every bit (8 per byte) in the bitmap indicates whether a particular sector on the drive is in use. If you can run dump on it you should see mostly 00 bytes. The beginning of it will have some FF’s because the bitmap file is there.

I’m curious now as to why you are running a QNX 2 system. Is it just for fun or does it have an important use. I don’t care which and I’m happy to give advice. There aren’t many people around still who know as much. If you don’t have the documentation and want it, let me know as I can probably find it around. Someone put it into a PDF a long time ago. You probably can find it just by googling.

Important use. 28 test rigs with qnx data acquisition pc’s. Did have near 40 at one time, before phasing out with Labview windows. It won’t let me delete directories as long as the bitmap for the directory is in it, it seems.

If you are saying that because of the bitmap file you can’t delete directories, you are wrong. You absolutely need to leave the bitmap file alone. There is some other problem. Have you tried using “zap”. If you zap a file or directory, it is removed without reclaiming any used disk sectors. It is useful if a file or directory is corrupted. You can get the lost sectors back with “chkfsys”. It’s not a bad idea to run chkfsys periodically. You don’t want to run it when there are any files open for write.

I guess I should have thrown this in for good measure. I’m still able to do contract work on QNX 2. Obviously it would be tricky to do remotely for you in Connecticut.

I mentioned you again to the director of the labs last week. He did seem somewhat interested. Right now though everything is up and running. I tell you, if you could make our app run on newer hardware, he would be extremely interested.

The last time that the question of running QNX 2 came up was a while ago, but I will summarize what I know.

The first problem QNX 2 had with faster hardware was the floppy drive. There was a 16 bit timing parameter that the OS calculated on boot time. I believe you can see it with the command:

$ tsk info

The problem was that the calculuation caused an overflow so the value was too small and the floppy driver would not work. A temporary solution was a simple program that force the parameter to 0xffff. This worked pretty well, however I suspect that with a modern Core 2 Duo processor faster it won’t work. An additionally related problem was that if you booted off a floppy to install, once the OS was running the floppy would not work, so another method to initialize the hard drive was necessary. One option was to boot over the Arcnet network. This would require that you have two QNET/Arcnet cards and a network cable and a working QNX 2 system.

The second problem had to do with the network. In order to setup messages across the network, a virtual circuit had to be created. This was done automatically if for example you opened a file across the network. The speed problem came in when a race condition occaisionally prevented the system from removing the VC when closed. This didn’t itself cause a problem however VC’s were stored in a table which would fill up. This is only an issue if your running system uses the network. There was a program that supposedly you could run periodically to clean up the table, but I was never able to get it to work.

It occurs to me that it will be very hard to find a modern motherboard with an ISA slot, although they may still be available.

Setting up the HD on another system is possible but can be quite difficult with QNX 2 as you need to give most HD driver Heads, Tracks, Cylinders parameters.

Then there is the possibility of using a VM, however it would need support for any hardware that your system uses. If your system just uses RS232 serial, then no problem.

I’ll pass this along. It would be the VM scenario I think. My director already has it running in Virtual Box, but not yet talking to the GPIB or the linksys Ether16 card. I’ll keep you posted. Thanks.

I forget what GPIB is but I doubt there will be a virtual driver. There was some support for ethernet but not from QNX. It came from 3rd parties and was very specific to the card, which probably is always an ISA card. If the VM will emulate that card, it doesn’t matter what the actual hardware is. BTW, QNET does not go over ethernet on QNX 2. Well one customer had QNX do a custom version for them. No way you will get a virtual QNET card.