Poseidon 2GHz - Network Problems Intel 82541

Ok heres is my problem.

I tried starting the Diamond Systems Peseidon 2GHz board which uses the Intel 82541 network card
(diamondsystems.com/products/poseidon) with a QNX Live CD.
But I get the impression that the LAN Card has not started properly as
unit is not able to get hold of an ip address of the DHCP server. The default driver QNX uses is the i82544 driver.

Is there a special command that I should issue when starting the i8544 driver ?

At the moment I’m Starting the driver like this

io-net -di82544 speed=100,duplex=1 -ptcpip

I also tried staticly assigning the IP address but it was still not able to ping my gateway. In fact the only thing I am able to ping is the
Peseidon board itself.

I have also tried to statically assign myself an IP address but still no luck …I can’t ping anyone else but myself

I also suspect that the MAC address reported by QNX is incorrect
(although I might be wrong) the MAC address reported is (00 60 E0 00 00 B6) which looks abit dodgy.

running the pci command gives me the following

> pci

Class = Display (VGA)
Vendor ID = 1106h , VIA Technologies Inc
Device ID = 3157h , unknown, unknown
PCI index = 0h
PCI Mem Address = a0000000h enabled
PCI Mem Address = dd000000h enabled
PCI int Pin = INT A
Interrupt Line = 11
CPU Interrupt = bh

Class = Network (Ethernet)
Vendor ID = 8086h , Intel Corporation
Device ID = 1078h , unknown, unknown
PCI index = 0h
PCI Mem Address = dfee0000h enabled
PCI IO Address = dc00h enabled
PCI int Pin = INT A
Interrupt Line = 11
CPU Interrupt = bh

Is it fine for the Network card and the VGA card to share the same interrupt line ?

I also tried booting the stack via Kanotix Live CD (a variant of
and Linux doesn’t recognise the card at all either.

Any help would be appreciated


Try toggling Assing IRQ to VGA in BIOS.
err, is there a bios? ;>

Its got a bios …x86 architecture …

…I don’t think its an IRQ issue …but more a driver issue