TCL /TK on Qnx4

Has anyone had any success in compiling TCL/TK 8.3 or above on Qnx4.25, irrespective of compiler and version of X?

old versions are available on qnx’s server:

Armin has also done the latest port.

Where would I be able to get hold of Armin’s build of the latest port?


He’s reading this forum sometimes, and usually post his software on sourceforge. I just checked but couldn’t find the tktcl for qnx4 (only for qnx6). You could contact him via his website or post to the openqnx mailing list where he is a member.

BTW, have you tried Bruce’s suggestion? … put=gplain …

Dave Hawkey also made the diffs available on his ftp site:

Thanks noc, I’ll give this a try today and see how far I get. If they work I try and get the binaries on an ftp site.


I have followed all the suggestions posted using both gcc and Watcoms cc, R5 and R6 of X windows. Once compiled I still get the same error. Tclsh always appears to work without problems but wish always SIGSEGV’s. I have tried 8.3.0, 8.3.5 and 8.4.4 of the tcl source. In one build I traced the error to an XNextEvent call, despite QLength (and XQLength) reporting there are events in the queue.



Are you using XFree86 4.x?
Also, have you tried to add -DNeedFunctionPrototypes flag to your cc command?

I was running testing on XFree86 4.2 and Qnx Xwindows R5. Incidentally I never tried the -DNeedFunctionPrototypes flag but thanks to the link you provided for me, I don’t have to worry anymore.

I need TCL for QNX 4.25 - would you please inform me of the steps required to port ?

tcl and tk 8.4.4 for QNX 4.25 … bin.tar.gz

It was compiled with XFree86 4.x from … index.html )

Thanks for the binaries - I was still curious if you had documented required changes to
get the compilation to work on 4.25.

He (Bruce) has published the instructions for both tk and tcl. Have you read the whole thread of this post? In particular, the 4th post where the Google groups URL of Bruce’s post was mentioned?