Profile customization

Im having difficulties configuring my own .profile

Is their a special format to these files, i noticed EVERYTHING is in an if statement but i have tried:

if test $(tty) != “not a tty”; then
bind ‘^I’=complete


bind ‘^I’=complete

in the following locations:


and it seems to NEVER actually use it, but when i use:

su - root

It sets the bind properly, possibly autobooting into the photon enviroment skips the .profiles and uses its own, or does the xterm have its own settings as well??

Also i wish to start qconn and inted on boot for easier devopment but adding the following to rc.local causes the system to lock at the boot screen after the nvSata search.

exec /usr/sbin/qconn
exec /usr/sbin/inetd

Try put this line in .profile


and put your “bind” line in $HOME/.kshrc (create it if there is non).

/etc/rc.d/rc.local is just a shell script, using “exec” is not a good thing, you
should be able just add the 2 lines below:



apparently my issue with rc.local was the defualt permissions were ‘-rwxr-x—x’ after i changed them to ‘-rwxr-xr-x’ they ran fine. (i also removed the exec lines as reccomended)

my key bind works on rlogin from the IDE and on text login, the pterm has a config file in ~/.ph/pterm/ptermrc and the file has garbage in it, i cant modify it in any way or else pterm does not start.

Ill just get use to using ls -l and dbbl-esc.

I noticed ls does not have the --color option avalible, is their another way to add colors? /usr/sbin/ptty -vt100 works on my debian box only.