What's the largest drive that will install Qnx 4.25?

What’s the largest drive that Qnx 4.25 will install on? I’ve tried a 250 GB drive in several computers but even making a small boot partition doesn’t work. Either stops with Press escape for alternate os and 2 dots or a line of dots and a C. I can boot and access the drive from a floppy and even mount and dinit the drive but I can’t make it boot. Any help would be much appreciated.

we use 160GB disks without problems, but i hope 250GB are working as well, try these:

  • boot image on cylinders <1024 - you probably need to make a separate small partition near start of the disk just for booting because if you place boot image above 1024 cylinders the qnx4 will not boot
  • Fsys -H disk250 - you do not need this during boot, but you need it in runtime

Thanks very much for the reply. When I boot from the floppy and fdisk the disk in Qnx I have partition 4 type 77 set up as starting cylinder 0 and ending cylinder 0 which gives a size of 16002 blocks 7 MB. The drive size shows as 131069 MB (cmos in this computer will only recognize half the drive) of 255 heads, 63 sectors and 16,079 cylinders. The drive is set to auto and LBA in the cmos. I don’t see how I can make a smaller partition than this in Qnx and it would seem from the above settings that Qnx is in the first 1024 cylinders. But it won’t boot. Comes up "Boot partition 4. Press esc for alternate OS and two dots. Can you tell from the above what I’m doing wrong? Thanks very much for your input.

The image is load by the QNX loader which goes through the BIOS read the HD. If the BIOS uses a different geometry then what the IDE driver used when it created the disk then this might explain what is going on.

try to use “Fsys.atapi fsys -i” (or Fsys.eide) when you are creating the disk

I was unable to get the Bios and Qnx to agree on the harddrive size with the 250 GB hard drive so following the suggestion of Mario, I switched to a 120 GB drive where I could get agreement and since Mezek has had success with 160 GB drives. With that drive Qnx and the Bios now agree on the size of the drive. Drive is set to LBA. I made the smallest partition I could starting and ending on cylinder 0 which produces a drive of 16002 blocks or 8001K. That’s the smallest that it’s possible to create on a drive of this size since both the starting and end cylinders are on cylinder 0. I can mount the drive and mount hd0t77 and dinit the drive with -b and -r but when the drive starts to boot from the hard drive I get a series of dots and then “…C” which from what I’ve read means the boot image isn’t inside the first 1024 cylinders. I don’t see why it wouldn’t be. Both the bios and qnx think the drive has 14593 clyinders, 255 heads and 63 sectors and the boot image should be on cylinder 0.

Mezek - Where does one get Fsys.atapi? I don’t seem to have it. It may be on the 2003 cd but although I can install from the cd (unsuccessfully) when I try to do a “ls” on it I just get “corrupted file system detected”.

One indication that something’s going wrong is when I run the install off the cd and select diagnostic mode for the install, at the very end of the install the message flashes by on the bottom of the screen:

 Unable to read hd.0.0.boot/images/install.1

I’m not sure exactly what that means, but it doesn’t look good. :slight_smile: Then it says take out the disks and boot to Qnx

Dare I say it? This is exactly the type of issue that QNX pledged continuing support on when they started moving to Neutrino. Too bad we don’t have the source to QNX 4, or someone could address the issue directly.

Just to remove possibilities, I tried the install on a 10 GB hard drive and made a partiion on cylinder 0 which gave me a 7 MB partition. Got the same “Unable to read hd.0.0.boot/images/install.1” when I tried to install from the 2003 CD and though I can boot and access the drive when I boot from the floppy in both cases the boot from the hard drive ends with a “…C”

After I get that error on the CD installation it says Qnx is successfullyl installed. Something appears to be screwed up on the installation cd.

  • We had similar problem

On our systems which are using SCSI we are unable to boot the disk if it was created (fdisk, dinit) on system which was not running “Fsys.aha8scsi fsys -i”. Thats why i suggested to you to try “Fsys.eide fsys -i”.

I guess the CD does not use the “fsys -i” argument for the Fsys.eide

I installed QNX on 500gb Hitachi SATA2 disk on ICH9R controller. I used Fsys.eide driver and legacy support in controller options in BIOS. Don’t have any problem with it.

Make sure you’re not using an old Fsys.eide, Fsys, and fdisk. The older ones don’t support > 36 gigs or so, iirc.