How to enable RS-232 mark / space parity ?

I’m sending data through serial port
from standard PC (Win XP) to SBS CL9 (QNX 6.3 SP3).

Everything works well (every baudrate with any stop bits
with parity: none, even, odd),
but when I set parity to mark or space it doesn’t work (?!).

When I set parity to mark or space I’ve got parity errors
(it’s about 80% of data and about 20% of data is correct).

So I turned off ignoring characters with parity errors:
new_termios.c_iflag &= ~INPCK;
new_termios.c_iflag &= ~IGNPAR;
new_termios.c_iflag &= ~PARMRK;
and now I receive all data and every byte of it is correct (!).

Mark / space parity checking works on QNX 6.3 ?
/maybe I have to change some parameters in serial driver ?