Booting QNX from floppy

I recently obtained a P3 box (computer A) that has QNX installed as its only operating system. It has a IDE HDD and a floppy drive, but no CDROM. Unfortunately, I can’t log in when it boots, as I don’t have an account, nor do I know the root password.

I figured my best bet would be trying to boot from a floppy image into a shell and edit the /etc/passwd file. I do not want to install another version of QNX on the HDD. I just want access to the installation that is already there.

So I’ve downloaded a few ISO’s from this site. I’ve been using the 6.2.1 and 6.0 images to make boot floppies. I’ve read numerous posts on this site, and I’m still confused. I’ve tried two methods: creating the floppy from the install window when the CD is placed in another windows machine (computer B), and I’ve tried using qmakedsk on instaflop.dat (on the CD), and floppy.144/floppydma.144 (from the installed files on on computer B). One of two things happen: either the disk asks me to install QNX on a partition, or i get errors like /.fileroot not found, etc., depending on which boot floppy I use.

I’ve also tried the demo disk, which runs fine (excepting the fact it can’t find my NIC), but there’s no terminal window.

I’ll admit that I’m new to QNX, and at this point, I am totally confused. Does anyone have suggestions for recovering the existing QNX install on computer A?



Ok, I found a IDE CDROM in my computer graveyard, configured it as master, and set the HDD as slave. I put the 6.2.1 CD in the drive and rebooted, pressed ESC at the prompt and got boot options F2 and F3. I pressed F2 (to run QNX from CD) and things started happening!

However, I am now hung at a graphical dialog box that’s asking me to verify my video driver settings. The problem here is I have no mouse or keyboard, even though I was able to use the keyboard to enter my boot choice.

I also got a message about not finding /io-net. Not sure if that has anything to do with it.

So, I’m a little further along, but still stuck. Anyone know why my mouse and keyboard stop functioning?


Let me guess, the mouse and keyboard are USB.

From memory, USB input devices are supported at this step on 6.2.1. Only PS2 keyboard and mice. Once you actually get past that, you can on subsequent boots have it look for USB devices but the default didn’t.