Please help me with the ORiNOCO wireless driver problem

I wanna install the ORiNOCO 802.11 b/g PC Card(8470-WD) under QNX6.2.1. But when i load the driver for Orinoco, the system said:“unable to init dll devn-orinoco:no such device”. (with “pin” command, the system can recognize it as a network device)

Having been trapped in it for quite a while, any help is appreciated.


Post the command that you are using

Thank you,
QNX6.2.1, laptop:Thinkpad T40
My steps as follows
Sock Func Type Flags PID Base Size IRQ
1 0 Network C–I-±–X–SAW 73742 0xffee0000 65536 11
1 Empty ----MF------------ None
2 Empty ----MF------------ None
2 Empty ----MF------------ None

#cd /lib/dll
#io-net -d orinoco -p tcpip
(i would like to install in first in the AP mode, initially i omitted all the options)
#unable to init dll devn-orinoco: no such device

#io-net -d orinoco ioport=0xffee0000,irq=11
then the machine broke down, needs reboot. sth wrong with my irq? How can i set the irq for different hardwares?


OK first thing to do is read the documentation on devn-orinoco - …

this will tell you what the command line sould be

try io-net -ptcpip -d orinoco irq=11,addr=0xffee0000

You will also have to add network name, key etc etc

The first thisn I should do is read your entire message, sorry for the hasty response!

Will have a think and post another response in a minute

Check the irq allocation, the pci utility will tell you what irqs are in use.

How is the pcmcia controller connected? I would assume it’s onthe pci bus.
So it should show up in the priyntout from pci-vvv

Does the T40 have an ISA bus?
If the controller is on the ISA bus, you will have to set the bios to keep irq11 away fom pci usage.

I have had this problem in the past, it took a bit of trial and error to figure out what irq was the right one to use.

It says that in AP mode(default), the options like channel, network, mac, mode, ssid are not needed. But i don’t know what the “station” option for my case.

pci info:
Class = Network (Unknown)
Vendor ID = 8086h, Intel Corporation
Device ID = 1043h, Unknown Unknown
PCI Index = 0h
PCI Mem Address = c0200000h enabled
PCI Int Pin = INT A
Interrupt line = 11

Class = Network (Ethernet)
Vendor ID = 8086h, Intel Corporation
Device ID = 103dh, Unknown Unknown
PCI Index = 0h
PCI Mem Address = c0201000h enabled
PCI IO Address = 8000h enabled
PCI Int Pin = INT A
Interrupt line = 11

Class = Network (Unknown)
Vendor ID = 168ch, Unknown
Device ID = 13h, Unknown Unknown
PCI Index = 0h
PCI Mem Address = ffee0000h enabled
PCI Int Pin = INT A
Interrupt line = 11

So, i think the last corresponds to my Orinoco card, right? Bren

I googled the T40, found it here:
How should i set the irq? use devp-pccard? I tried, but "“pin” still had the same irq results.

I tried, but still not OK.

Thank you for your suggestions.

Hang on, I made the assumption that the wireless card was plugged into the pcmcia slot.
Is this the case or are you using a mini pci card?

PC Card slot, not mini pci.

Thank you

Hi Bren,

What is your Orinoco card model NO.? Mine is 802.11 b/g PC Card Gold (8470-WD ).


I will have to check.
I have not worked on this system for a while, and am now with another client.
I do have some spares at home, I will check tonight.

My Orinoco is manufactured with the Atheros chipset, I learned from Hugh Brown that QNX does not support Atheros chipset. So i guess i need to have the Lucent Orinoco ones on the market.

Look forward to your Orinoco model… :smiley:



Sorry, forgot to look at my spares last night, will try to do better tonight.
I too ran into this issue with the Atheros chip set, it was a real headache on my last project, finding a wireless card supported by QNX that was not on the verge of going out of production.
My last batch of PCMCIA cards were purchased on Ebay, how’s that for desperate.
The current system use a mini-PCI card based on the prism chipset.

Will update later if I have any (real) orinoco cards.

The cards I used succesfully were the Proxim Orinoco cards, part numbers:
8420-WD Gold Card (b only)
8481-WD Silver Card (a,b + g)

I think from memory the other difference was the silver card only supported 64bit WEP.

I have a few of these so send me a PM if you still need to get hold of one.


Great! Brendan
What are the chipset of the two kinds? And do they work under QNX6.2.1?
Sorry, I just wanner be more sure. I have been wasting money and time on the selection.

Thx and regards,

Hi, Brendan

I finally bought the previous Lucent Orinoco 11b PC card silver, and it works well!

Thanks and regards