Can't auto login in console mode

Hi everybody.

I’m trying to auto login as root at boot time in my embedded system (QNX 6.3 SP3, CPU x86) booting from a flash disk. I’ve modified the ttys file where I’ve put the line:

  /dev/con1 "/bin/login -f root" qansi-m on

But at last the system ask me for the password. I don’t know wether is something wrong in my system performance. My boot script (the .bsh file in QNX System Builder) is:


procmgr_symlink …/…/proc/boot/ /usr/lib/

display_msg “Starting…”


display_msg “Starting pci-bios server…”
pci-bios &
waitfor /dev/pci

display_msg “Starting up console driver…”
devc-con -n4 &
waitfor /dev/con1
waitfor /dev/con2

display_msg “Starting EIDE driver”
devb-eide cam quiet blk auto=partition eide master
waitfor /dev/hd0t77
mount -t qnx4 /dev/hd0t77 /

slogger &
waitfor /dev/slog

display_msg “Starting pipe manager…”
pipe &
waitfor /dev/pipe

Some common servers

mqueue &
devc-pty &

reopen /dev/con1
sleep 1
tinit &

display_msg “End of boot process”

The system doesn’t provide any error message.
What can be happening?
What system files/libraries are involved in the whole process of login in?

Thanks a lot.



Everything looks fine to me. The only difference from what you do and what I do (same flashdisk setup as you use) is that you run tinit in your boot script and I run tinit from my rc.sysint file (which I execute from my boot script via ‘sh /etc/rc.d/rc.sysinit’)

Now on my system when it finishes booting I noticed I get the ‘password’ prompt on the screen. But in fact, QNX did auto login as root because in my root .profile file, I auto start our processes and they are indeed started. Furthermore, despite the presence of the ‘password’ prompt, I can type ‘ph’ and start photon which starts logged in as root because when I create a console in photon I am auto logged in as root (no password prompt).

So you might want to check to see if you really did get auto logged in (by printing some message in the .profile file for root) but are just seeing the misleading ‘password’ prompt (and no, I don’t know the reason it’s there).


Thanks Tim.

Then, I think that both of us are seeing the same, but I need to operate in con sole mode and use some system utilities, and I can’t do that since the system remains asking for the password ever.

Is it possible my system is missing some important files, such that password database, etc…?



No, I don’t think so since I know I have all my files and I see the same thing.

Although I haven’t tried it, I think the line:

‘reopen /dev/con1’ is causing the problem somehow with the tinit interaction.

I also have that artifact line left over in my build file which is why I suspect it to be the culprit.

You might try removing it or fiddling with the order (maybe place it after tinit) and see if that fixes your issue.


Thanks Tim. Let me try and see.