DHCP Server - QNX4 ??

I was looking at the QNX4 documentation and I found a dhcp.client but can you run a dhcp server?

If the answer is yes could you please provide an example?


I don’t know of a dhcp server for QNX4, that doesn’t mean there isn’t one or that you couldn’t port one. My guess is these days most people just use the dhcp servers usually embedded in routers.

The dhcpd server code port real easy to QNX4. I don’t have the info with me where to get it but it should be easy to find via google.

If you don’t find it after the holiday I could send you the full source and/or binary for QNX4.

In my Linux-gentoo I use isc.org/index.pl?/sw/dhcp/

Yep that is the version I worked with, for QNX4 we used version 3.0.4 ( don’t know why we used that perticular version)

Can you compile this source code with watcom?


Hello Mario,

can you please place it on the download page for QNX4 on openqnx?
I’m also interested in a dhcp server but dont want to go through the porting stuff.
Please forgive me for my laziness.

It would probably take me more time to package it then for you to port it ;) Please forgive me for my laziness loL!

Hi Mario,
I’m actual portinge the dhcpd4.0.1 package to QNX4 and had a big problem with the dhclient.
The TCP4.25 implementation of sendto() is not working properly.
The malfunction is also described in the QNX Knowledgebase.
Do you have any fix or trick how I can send a ethernet broadcast for the DHCP to the IP address
I’m only able to send local network broadcasts like

Do you have used the sendto() out of the TCP5 package?

We are using 5.0. Sorry.

Hi Mario,

the difference between TCP5 and TCP4.25 is not ab ig issue in porting the dchpd.
The big stuff is the dhcp.4.1.1, Someone inserted there constructs not working in different operating systems.
After spending nearly one week to port it i was a little bit frustrated and tried it again wit dhcp3.0.7.
These took about 3h to bring it to run in QNX4. Either on TCP425 or in TCP5 :slight_smile:)