"sin" command takes eons

I’m trying to debug some applications on a QNX6 server and am getting quite frustrated @ the amount of time it takes to run a simple “sin” command. It literally takes over 5 minutes to run. I’ve got the system monitor running and it shows low CPU usage and stable ram usage. Has anyone else had this problem? How do I fix it? Thanks!

What version of QNX are you using. If you are running your own programs it’s possible that they are receiving a message from sin and are not handling it properly.


Are you running the ‘sin’ command directly on the QNX machine (console or under Photon) or from the Momentics Eclipse environment via a Windows machine?

Assuming you are using QNX 6, what happens if you try a ‘pidin’ command or a ‘hogs’ command? Do they also take 5 minutes to run?


I have also seen this problem. We just gave up on sin and use pidin exclusively. Never really paid a lot of attention since pidin is fine for us. We’ve had this problem since the 6.2 days, by the way, on every machine with every configuration of every version/patch of QNX 6 we’ve tried.

-James Ingraham
Sage Automation, Inc.

In all cases that I’ve seen this it was because a program was not able to handle the message receive by sin. And most of the time it’s not one of the QNX program, that not handling these messages properly ;-0

Ironically, the program has to announce to the OS that it does know how to handle the message before this can happen.

Many thanks to all the replies!

I tried the pidin and hogs commands and they both run immediately. That pidin command in particular will be of great use.

I am running the sin command by connecting to the server using Phindows, which then had the Photon GUI.

The server is running a lot of code that didn’t come with the OS and I think is very likely they aren’t responding to the sin commands properly. I am also having problem with this code as the processes often die rusulting in downtime. Perhaps these are two symptoms of the same problem.

Thanks again for the input!