QNX2 in VMWare

Has anyone been able to get QNX2 running in VMWare?

Using a USB floppy drive I’ve been able to start a new VM, boot the QNX2 install floppy, and start the installation script. It hangs during dcheck.

Doing the installation manually, and skipping dcheck, almost works but the VM hangs halfway through using ‘backup’ to copy the files to the VM disk.

Anyone have any luck with this? I’m pretty much a VM newbie and am unfamiliar with any tricks required to get old OSs installed.

I haven’t tried to install QNX 2 from the installation disks, but I’ve gotten it up and running from a boot floppy, and transfered my entire system over.

There aren’t many options for moving data from and two a VMWare QNX system, but my Parallel Port Zip driver seems to work ok.

Before I went to VMWare, I tried Microsofts VM machine, and guess what, it didn’t work very well.

Mitchell, did you you your parallel port zip driver to move your system over? Or did you use a floppy?

Booting and running off the floppy works fine but setting up the virtual disk is where the problem starts. The virtual disk can be fdisked and dinited but attempting to dcheck it hangs. Skipping dcheck and copying files to it from the floppy works for 10-20 files before it hangs. Maybe I should just copy over the bare minimum by hand, make it bootable, set up a minimal sysinit file with the speed correction patch and see if it will boot off the virtual disk. Once it does that maybe the floppy will work OK.

I installed it from some boot floppy, I had the HD size to something like 200Meg though. This was with VM5

With VM6 it’s not working on a Dell D820 with the VM set to one core and a 500 meg disk. Manual setup failed with the same results, the VM just hangs after copying a few files - speed_correct didn’t help. Hmm.


I setup the disk using just a customized boot floppy, and then copied everything over with the Zip drive.

I did this all about three months ago, and can’t tell you whether or not it was VM6 or what. Just what I was able to download free.

I made an image file of the QNX2 boot floppy and mapped it into the VM as drive A.

The VM boots from the image file fine, but it still hangs as it did when working directly off the floppy.

VMWare 6 may no longer work with QNX2. I’ll try it on another machine to see if the symptoms remain.


Do you really need a 500Meg disk?

Way back in the day when I worked with QNX2 (89-92 time frame) hard disks were pretty much all around 40-100 megs in size.

I don’t ever recall trying a disk that big because they didn’t exist back then.

I wonder if QNX2 can’t handle the size of the disk when doing the dcheck. Maybe try a 100 meg disk and see if that helps.


I just installed QNX2 on a couple of old 540 MB IDE drives for a customer, and used to use it with 900MB SCSI drives, but I’ll give it a try with a smaller VM. Won’t hurt to try. Thanks.

It failed with the same symptoms with a smaller 100MB VM disk , but it was worth a try.

I have tried to install QNX 2 from the boot floppy on Virtual PC 7 on a 500 MB virtual Hard Disk.
fdformat 3 and dinit 3 +h worked, but it failed at the dcheck 3 step.
I changed some settings in the configuration of the BIOS of the virtual machine in ‘Advanced - IDE configuration’ :

  • PCI IDE BusMaster : [Disabled]
  • LBA /Large Mode : [Disabled]
  • Block (Multi-Sector Transfer) : [Disabled]
  • 32Bit Data Transfer : [Disabled]

and then dcheck worked as well the QNX 2 installation.
Currently I have 234 MB data on the disk and it have no problem with it
I’ve used disk.ata to mount the disk

To transfer the data on the virtual Hard disk :
- used QNX formatted floppy disk from real QNX 2 machine to virtual QNX 2 machine
- used DOS Formatted floppy disk and dosfsys on the virtual machine ( files names must not exceed 8.3 naming format )
- used serial port with qtalk/qcp

Perhaps these Hard-Disk options are as well available in VMWare ?

psimler, that’s good information, thank you.

There doesn’t seem to be a way to adjust virtual machine BIOS settings in VMWare 6 but I’ll research it some more.

Silly me, I was looking for a menu somewhere to change BIOS settings and didn’t realize I had to press F2 during boot to access a BIOS setup menu. VMWare 6 gives about 200ms to click in the console to give the VM focus and press F2.

Anyway, QNX2 is booting and running fine in the VM now.

For posterity, this is on a Dell D820 2GHz dual-core notebook. The QNX2 VM session is allocated 16MB ram, a 500MB virtual drive, and a single cpu core. In the BIOS the processor cache was disabled and, with the disk.at (not disk.atc) driver it booted and installed from the boot floppy image file. I also changed the BIOS multiprocessor spec setting from 1.4 to 1.1, since the on-screen note said that might have to be done for older OSs, but I’m not sure if that made a difference.

Now for the drudgery of moving everything over via floppy. Maybe I’ll just hook up a serial port to my QNX2 desktop, kick off a qcp transfer and let it run for a couple of days.

Thanks for the tips!

Ken, Parallel Port Zip drive, $10.00 on eBay. If you don’t have the driver anymore, I’ll send it to you.


I discarded that idea because the notebook doesn’t have a parallel port but usb-parallel converters are cheap enough so that’s what I’ll do.
Does your driver support 250MB zip drives too?

I’ll be happy to pay you for the driver since I never bought a copy from you.


You could get both a parallel and usb drive.   The disks are interchangable.   Yes it supports 250MB.   And no, we go back too far Ken.   You will just have to take it.  


Sold :slight_smile:

Thanks, Mitchell, you are a great help!


Send me your mailing address at [maschoen@pobox.com](mailto:maschoen@pobox.com)

Mail sent. Thanks again, this will help a lot :slight_smile: