Momentics compiler doesn't recognize PhAB types?

I wonder if somebody can help me with this. I’m developing a Photon Appbuilder project in QNX Momentics v6.3. During the
project build
I’m getting these errors that make it look as if the compiler didn’t recognize any PhAB types, such as ApWidget_t. For
example, I get the following compiler error

data definition has no type or storage class abwidgets.h

The line producing the error is:
ApWidget_t AbWidgets[ 68 ];
which is the only line in abwidgets.h

apparently the compiler is not recognizing the type ApWidget_t even though Appbuilder has included Photon library
headers in the project. In fact, the header file Ap.h appears in the list of includes for the project. Can anyone tell
me what’s wrong?


there may be something in your global header file that causes this problem.

Did it ever work before?

Can you create a new Photon project that compiles correctly?


Yes, I can create a new Photon project -I use AppBuilder to create the UI files- and it compiles.

I created the original project in QNX6.2 using PhAB, Now I’m trying to port it to a QNX Momentics v6.3 Windows host, so that I can use the IDE for debugging. To do that I created a new PhAB project and imported the apabb.* files from the old project plus the source code in src and wgt. However, when I try to build the new project it looks as if the compiler can’t find Ap.h at all (doesn’t recognize data types associated with Photon, etc.)

This doesn’t sound like the correct procedure how to port a old PhAB project from 6.2 to 6.3. Did you try to open the old PhAB project with the new application builder? (I expect the project to be converted automatically - but I didn’t try this myself).

Maybe somebody else could comment on this.


You’re right. Eventually I tried importing the widget files into Appbuilder instead of the IDE, and that worked. Now I can compile without problem. Thank you.

good to know it works this way - thanks for the feedback