Installing a USB mass storage device

Hi! I’ve actually have a few questions…

  • I’ve been trying to install a USB mass storage device for a while now, and i haven’t had any success on it. I’ve tried to follow the instruccions in QNX documentation, but nothing… and also checked some of the topics here at the forum, but zero, jeje… i’m kind of new on this, don’t know how to move around QNX yet… could you give me a little step-by-step guide on how to install it and access it from QNX?..

  • If i installed QNX in a partition of my Disc Drive, can I see the partition where I have windows installed from QNX?

  • and also, where can I find some kind of a begginner’s guide for QNX, or something a little more easy to digest to begin using this OS than the documentation that comes with it? Thanks!


Same problem!!!

I’ve tried simply with

Fsys.umass &
io-usb &

I’ve received e message with connected i-stick usb 2.0 key, but we are files? i don’t specify any mount path…

What version of QNX are you using?

If it’s 6.3, SP3, then the USB sticks should be seen automatically and will be mounted as /fs/hd1.

If it’s earlier versions like 6.2.1 or earlier then you need to do the following (as root)

io-usb &
devb-umass &

Your drive should be detected at this point.


This shows the detected disks. You should see your hard drive and your USB drive. The USB drive will look something like:


If this is a DOS formatted USB you mount as follows:

mount -t dos /dev/hd1t77 /fs/hd1

If this is a QNX formatted USB you mount as follows:

mount -t qnx4 /dev/hd1t77 /fs/hd1

Then you can see the files by doing

ls /fs/hd1

Note: the /fs/hd1 can be any name you chose.


To mount the DOS partition of the hard drive, follow the instructions from ‘df’ onward.


Same problem: I’m booting into QNX Momentics 6.3.2 as a livecd, but my USB hard disk (power externally) is not being detected. Will this be solved if if install it into a partition? I don’t know much about QNX yet. Where can I get the relevant documentation, etc? Thanks.


So after booting into 6.3.2 and plugging in the USB CD-rom what does a ‘df’ command show?

What does a ‘usb -v’ command show?


Thanks, but I figured it out. It was because the hard disk has NTFS partitions only.