boot failure with Intel Xeon computer

I tried installing QNX 6.3.2 on a Intel 2.33GHz Xeon DC 5140 processor (HP xw6400) and after altboot…
it says “Can’t locate PNP nodes”
Any idea? I tried many different option in BIOS from disabling PCI E and PCI ROM download and other option but no success.



I have exactly the same pb.
When I try to install QNX 6.3.2 on my XW6400, I have “altboot…Can’t locate PNP nodes”
And just after, the system freezes!
I need to restart the computer.

I think I have tried a very lot of configurations I Bios Setup, but no effect!
I tried also to plug another Hard drive, already installed… but same result! The system hung!

Had you solved your (our) problem?


HP computer can be weird ( even XP SP3 has trouble on them )

I have reported the issue to QNX support and I think it’s one of those things where if enough people report on them QNX will release a patch. So I suggest you call QNX and report the problem.

I am installing QNX Momentics SDP 6.5.0 Self-hosted 30-day Evaluation on HP PC (XY139EA, SATA AHCI HDD, SATA optical drive) and:

  • during installation from burned CD: Can’t locate PNP nodes, but installation continues OK,
  • during installation also:
    gzip: stdin: invalid compressed data–format violated
    An error occured during the installation.
    Do you wish to continue (y/n)?
    But we cksum-med downloaded ISO file and also Verified burned CD (ImgBurn, low burning speed) after burning - everything was OK.

QNX6 seems to work after installation, but we are afraid what was that: gzip: stdin: invalid compressed data–format violated - which file/s are not installed.

At each boot of installed QNX6 it writes the same “Can’t locate PNP nodes” too - for the first time immediately after selecting partition, second time after some steps of boot process: “Enumerator error - Can’t locate PNP nodes”.

Any ideas?

Re: The PNP Nodes message:

  1. Have you turned off PNP Mode in the Bios? QNX PNP mode doesn’t work with this turned on.
  2. I believe you get this message when QNX finds a piece of hardware (usually built in Ethernet card) that it doesn’t have support for.