Embedded Photon & keyboard problem

I’ve faced with problem trying to embed Photon. So, my keyboard doesn’t work. There is no problem with the mouse. I ran devi-hirun with argument from pidin arg, but only mouse appeared.
What can it be?

I tried this: devi-hirun kbd fd -d/dev/kbd ps2 mousedev &
And this: devi-hirun kbddev ps2 mousedev &
With the same effect. :frowning:

OS: QNX 6.2.1A PE
“Embedded” PC: x86, Celeron 466, 256 MB RAM, HDD 200 MB.
Keyboard: PS/2
Mouse: PS/2


devi-hirun kbd kbddev ps2 mousedev


This helps if only I run it by hand. If I run devi-hirun kbd fd -d/dev/kbd ps2 mousedev
by hand from null-modem terminal, it works too. I tried to run devi-hirun with 10 seconds pause with negative result. I tried to run devi-hirun twice, it works only if I run it from null-modem, but not from startup script. :open_mouth:

You originally stated that this was embedded photon, so I assumed that you had no devc-con running. The fact that the first invokation works from the command line (i.e. fd -d/dev/kbd) indicates that you are running devc-con. This means that you shouldn’t use “kbddev”. You might try adding a “-r” to the kbd parm in your script eg.

(assuming devc-con already running)

devi-hirun kbd -r fd -d/dev/kbd ps2 mousedev


I’m sorry, it didn’t help. I tried
devi-hirun kbd -r fd -d/dev/kbd ps2 mousedev
devi-hirun kbd -r kbddev ps2 mousedev
without any visible effect.
But you’re right, I really run devc-con. At this time, I start Photon from ksh on target computer or by null-modem connection from remote machine. So, I can post my startup script if it’ll help to solve the problem.

Now everything is O’K. I ran devi-hirun -vv and saw error messages - devi-hirun couldn’t find *.kbd files, then I put some. Another point was that devi-hirun tried to look into /etc/config/trap, there was no such directory. I’ve created one. Now everything work.

Thanks to all and especially to rgallen, who makes me to watch keys of devi-hirun. In short, RTFM. ;)

No problem, I should have suggested the “-vvv”. Glad you got it working.