Boot Cd fails-QNX Neutrino (6.3.2) Host on VIA Eden/CX700 M2


I downloaded the latest version of QNX Momentics 6.3.2 Neutrino Host CD ISO from QNX download center.

I tried booting it (after burning the ISO to a CD) on my VIA Eden Process / VIA CX700 M2 graphic chipset on my computer but it does not boot. I get the message:

Hit ESC for .altboot

and then it just restarts the system again.

How can I know if my configuration is supported or not?

I also have seen this problem using a WinSystems LBC-GX500. This is a Geode board.
It would eventually boot. I have felt like it to be a spec problem with-in the BIOS. The entire
spec for the CD drive might not be followed. This was true with a Micro-sys board.

Thanks for your reply. In my case my system just keeps restarting. So I can’t even boot.

Is there any way by which we can get technical support assistance from QNX people?


You can only get official tech support from QNX by paying for it. However quite a few QNX people frequent this board and post answers to questions.

You didn’t describe much (hard drive, CPU, any installed boards etc) about your system or else I don’t recognize what it is from your description.

Assuming it has a BIOS, I’d try changing a few options. Especially if you have a SATA harddrive, you should enable legacy mode so it operates as an IDE device.

The behaviour your describing would seem to that starting drivers (typically looking for a harddrive) to interrogate for hardware is causing the computer to reboot.

I’ve also seen similar behavior on a PC104 board when the 5V power wasn’t quite up to spec (giving about 4.5V) and once the O/S started consuming CPU/powering USB devices it would overdraw the powersupply and reboot the board over and over again.


Thanks Tim. I think you made a good point about the legacy mode. Sorry for not describing the problem in depth.

I have an EBX board with VIA Eden C7 processor with 512 MB memory and Two SATA drive connectors and two PATA drive connectors (traditional IDE drives). I have tried combination of SATA/PATA but was not able to get it working. I do see an option for legacy/native mode in my BIOS. I will give a shot at it and see how far I can get. I did some research on qnx website and the closest thing that I found was “devb-ahci and devb-eide compete for the same bus, which results in a hang.” … es_booting

Not sure if anyone else faced a similar problem.

Thank you once again.


Hopefully the Legacy mode problem solves it for you.

Is your setup similar to the link you provided (built in CD-Rom in addition to the harddrive)? If the legacy mode thing doesn’t work, you might try unplugging the CD-Rom and using a USB CD-Rom to install the O/S to your harddrive.


Thanks Tim for your further help.

  1. Legacy/Native mode thing did not work.
  2. I tried USB-CDROM after disconnecting IDE CD ROM. did not work
  3. I also tried SATA CD-ROM. That also did not work.

In all the above 3 cases, the system gets restarting.


Out of curiosity, is there a Hardware Health section in the BIOS on this board? If there is, check to make sure the voltages (12 and 5) are correct.

As I mentioned, I had some PC 104 boards that were slightly off (4.6V) that would do the same thing when trying to install the O/S. Once I correctly the power supply everything installed smoothly.

If that’s not a problem in your case then it means something else isn’t compatible with QNX on that board (you don’t have any ISA cards or anything plugged in do you?) that causes a re-boot when it’s interrogated by the O/S.