io-graphics problem


I am trying to get Photon running on a Freescale MPC8349 board with an ATI Rage 128 PCI video card. At the moment I am starting io-graphics with the following line:

io-graphics -dati_rage128 vid=0x1002,did=0x5245,index=0,xres=640,yres=480,bitpp=16,photon -pphoton

and it exits without an error. If I run sloginfo I get the following:

Jan 01 00:12:54 1 8 0 phfont_init
Jan 01 00:12:54 1 8 0 phfontXX started OK
Jan 01 00:12:54 6 8 0 pci_init: found PCI device 1002:5245
Jan 01 00:12:55 2 8 0 mode init() failed: Invalid argument
Jan 01 00:12:55 1 8 0 fontserver: clean
Jan 01 00:12:55 1 8 0 Received terminate request, exiting - EOK

I believe the mode init() failed line is coming from io-graphics although I don’t know what the cause of it is. If i run io-graphics with DL_DEBUG=1 set, it doesn’t seem as though there are any libraries missing. I have tried the latest patches for io-graphics and it hasn’t made a difference.

Does anyone know what the “mode init() failed: Invalid argument” line is indicating?


My guess would be that the driver is unable to set the gfx mode you requested.


According to the information for the driver on the QNX site: …

it should be capable of the resolution and bit depth I have selected.