Boot Problems


I am aware that my problem has come up here in the past but I couldn’t find any answers that would help me.

I have spent the last 5-6 hours trying to install qnx. I have the 6.2.0 iso on a cd (6.2.1 download was unavailable). My PC has 2 6 gig hard disks, the primary (master) has win 98 on. I was hoping to install qnx to the secondary disk. I have done so many times and I can’t get it to boot.

I have installed qnx on my windows partition, on it’s own partition, on it’s own disk, using qnx bootloader, using dos config.sys files, and even using a third party boot loader but I always get this message when it tries to boot:

/.diskroot file for root not found on any filesystem
unable to locate fs-pkg

From the other posts about this I have discovered that this can be due to masterless slave IDE channels and DVD roms e.t.c. but my 2 disks are set as primary master (the windows disk) and primary slave and I also have have 2 cd rom drives a normal cd rom (which I’v been using for install) setup as secondary master and a cdrw as secondary slave.

I have managed to boot qnx from the CD and from the hard disk from the CD (if you know what I mean) and it looks excellent. I would love to get it installed properly though.

Can any one help?

Thank you in advance. I hope you understand my problem. Any ideas are welcome.


I’m not sure I understand your problem. To boot QNX from second drive you have to use ipl-diskpc1, it will be installed in MBR on first drive during installation, it gives your ability to press F1-F4 to select boot disk and boot partition. Of course, you can use third party boot loader with such feature if you have/know any. The second issue is next: during installation on second drive ‘dinit’ didn’t get ‘-d0x81’ option, so you have to change it somehow… for example, ‘spatch /dev/hd1t79’ and edit byte with offset 0x11 from 0x80 to 0x81.
But anyway, problem with /.diskroot means something else. I’d like to add to your discovery list an item: try hit Esc when prompted to do so during systems start up.

Thanks for the reply

To clarify a bit then, it appears I have installed ipl-diskpc1 since i am asked which partition to boot from everytime. if I choose F2 (drive 2) where QNX is installed I get the usual ‘esc for .altboot’ and then the dots but the dots keep going for about 8 lines and then stop and nothing else happens.

I’ve tried hitting esc but it doesn’t appear to do anything.

I read somewhere else on the noard that you can simply add a blank file named .diskroot into the root folder to get around the other problem - I haven’t been able to try this yet.

I will have another go and see what I can do.

Thanks for your help


Sorry. To clarify again.

The problem I described in my original post only happens when I install QNX in a Fat 32 partition.

If I install it to it’s own partition from the CD (infact it’s own hard disk) it does what I mentioned above: Having selected it’s hard disk, it gets to the dots after ‘hit esc for .altboot’, fills about 8 or 9 lines of the screen with dots and then stops and does nothing until you restart the computer.

I have tried quite a few times to hit esc before the dots appear but it happens to quickly and I can’t get any thing else to happen.

How would I do this? I have tried using dinit on the hd1t79 partition affter booting from the cd (this was suggested somewhere else) but it doesn’t seem to have acheived anything. I have probably been through each install process at least 10 times now, I’ve tried 3rd party bootloaders, I’ve even downloaded 6.2.1 and tried that (the only reason I had 6.2.0 was because originally the 6.2.1 download wasn’t available), I’ve tried different CD ROm drives and even fidled with my hard disk settings in the bios. I’m stumped why it won’t boot.

Please suggest anything that might help. I really like QNX when I get into it (only from the cd so far).

Thanks again


as root, run “spatch /dev/hd1t79”
and you will get a screen:

hit “g” to Goto 1:11 for offset 0x11
hit “e” to Edit it, to change it from 80 to 81.

Thanks for that noc.

I have made a breakthough. By removing my windows hardidsk and setting up the QNX one as primary master I have succesfully managed to install QNX. It boots and runs fine with the drive as Primary master. When I put the windows disk back in and put QNX disk back to primary slave I have the same problem as above (not doing anything after several lines of dots). This is annoying becauase I would still need to use windows for certain tasks so I really need to dual boot. I also have afeeling that windows won’t boot from a slave disk either (although I haven’t tried this).

Another question. I have a fairly standard old ethernet card in my pc which is connecing to a router in my hoese for internet and file sharing between my other pcs (all windows). When I managed to run QNX before (from the cd) it found this card and sorted out the network settings automatically (I could access the internet - I didn’t bother trying to sort out file sharing). Now when I get QNX to run (from the master IDE channel) it won’t even find a networking device. It mounts to devices /dev/ser1 and /dev/ser2 which it seems to think are modem (serial) devices but no ethernet device so I can’t set up TCP/IP stuff at all. It might be worth pointing out that I don’t have a modem in the PC! infact all the hard ware is a video card a sound card the ethernet card and th disk drives.

Any ideas on either of these problems?

Thanks for your help guys


The line of dots after “Hit Ecs for .altboot” message is expected behaviour for QNX installed on second hard drive. If ‘spatch’ is hard for you, you can use any disk editor to edit boot sector of QNX partition, for example Norton Disk editor (there is old good one for DOS :slight_smile:). Also you can go this way:

dd if=/dev/hd1t79 of=bootsect bs=512 count=1

Then edit the file bootsect in any hex editor and put edited file in place:

dd if=bootsect of=/dev/hd1t79

Or if you already have QNX 6.2.1 CD you can go another way, just booting off QNX 6.2.1 CD (prev. ‘dinit’ doesn’t support -d option) and carefully ‘dinit’ QNX partition after installation:
#dinit -h -d 81 -r /dev/hd1t79
Just for record, Windows 9x as well as DOS won’t boot from second drive. You can spatch DOS bootsector, no problem, disk number is in offset 0x24 in FAT16 bootsector, but it won’t be able to find and other funny stuff. Windows NT or 2000 could boot from second drive, but it is much more work then boot QNX from second drive. Also, if your Windows is one of NT flavour you can use ntldr to boot QNX.

As for network card. I don’t think it’s good idea to put questions all-in-one. It would be nice if you tell us what kind of network card you have (ISA or PCI, builtin m/b) what is chipset etc. Since it worked with QNX 6.2.0 and isn’t working with 6.2.1 I can only guess it is RTL 8139 card or such and as soon as you install Momentics package from CD repository everything will work.

Thanks for that.

Well I actually tried the unthinkable and tried setting my windows disk as the slave and using a third party bootloader to select which disk to boot from. It WORKS! I wasn’t expecting it but since DOS doesn’t recognise the master drive at all (because it’s not a dos format) it will boot up from the secondary drive no problem.

So I now have QNX 6.2.1 on my primary master drive and win 98 on the primary slave and they both boot fine.

I have completed the install of QNX now (from the repository) and all works fine except for this networking thing.

I will have a look around and then post a new question about it if I need to.

Thanks again.


Do you mind telling me what the third party boot loader is? I’m in the same situation too, but I need the bootloader for more OSs (one for a computer running windows 2000 /Linux, one for a QNX/Windows 95 computer).

The one I’m using currently is called OSL2000 [website]. It is only shareware and ocasionally pops up an annoying nag screen.

I have found one that looks better here again it is only a triall but it looks pretty good (I haven’t got round to testing it yet).

Otherwise I guess you could use GRUB or something.

I hope this helps