Remote debugging tcpip problem

when i tried to debug my remote target, the target gave me the error:
"tcpip: blown stack handling 0x102. See “stacksize” option. " then after this came out the bad file descriptor for
server and client thread.

my boot script for the network setup:
/proc/boot/devp-pccard ss -m
waitfor /dev/pccard 59
io-net -d ns83815 -p tcpip -p qnet bind=en0
waitfor /dev/io-net/en0
waitfor /dev/socket
ifconfig en0 ... netmask

display_msg "configuring adhoc network mode"
mount -o channel=11,network=mywork,mode=adhoc -T io-net	
waitfor /dev/io-net/en1
ifconfig en1 netmask


io-net, by default uses, a very small stack for all the threads it creates. If any thread in a driver or protocol module uses too much stack space, you get this error. A common cause is the use of slogf(), which uses a lot of stack because it does the formatting on the stack. Therefore QNX invented nic_slogf() which should be used by drivers but maybe your driver does not.

You must start io-net with something like stacksize=100k or so.


true, now it works fine, thx.