Hi All

I am trying to use the HAM on an x86 platform.

I have tested out the configuration out from a shell and all works well.
The problem comes when trying to run the HAM from boot!

I have a sysInit script that I call from the boot script, here I start various driver and set IP address etc.

I have added the HAM to this script but it fails to start.
There are no error messages printed even though I have lots of verbosity set.
The script runs in a full shell (not ESH or FESH).
The script is at this point running as root, from the boot script.

The command used in the boot script is as follows:
reopen /dec/con1
[+session] sh /sysInit

I have also tried running ham from the boot script.
It also fails quietly.

Once booted I can start ham from the command prompt with no problems.

I’m confused!!!

Just a guess here, but if you can get syslog running before you start ham, you might find out why it is failing.

My guess is HAM needs a library or config file that isn’t included in the IFS and isn’t accessible until after the drive is mounted, symlinks are set, or something like that.

Thanks for the ideas guys.

I tried running syslod and slogger, there are no errors reported.
I also set DL_DEBUG=1
Strangely, starting ham produces no dll loading messages (with ham loading correctly).
I assume that no extra libraries are required.

One thing I have noticed, my embedded system is 6.3.0
I copied the ham binary from my Momentics install (6.3.2).
Could be the root of the problem.
I will dig out the original 6.3.0 disks to try and find the original binaries.
Am I clutching at straws?

Hmm, I think the HAM was part of the Critical Process Monitoring TDK in 6.3.0 - so it was not part of the standard distribution. Why not port the entire system to 6.3.2?