Browsing QNX directories in windows

I have Windows XP machine cross cabled with QNX 6.2.0
Now i want to browse my files in QNX machine through windows machine.

I know there are some utilities like wsFTP helps to transfer the files from QNX to windows, but i want some thing like SAMBA that would browse thro the QNX directories from windows machine.

I tried SAMBA but i could not make it, if any one have the procedure to make this SAMBA to work in QNX would also be equally helpfull.

Thanks in Advance

Samba works fine for me and many others. What version of SAMBA are you using, what does your config file looks like.

Make sure all the username/passwords are the same on every machine involved, then use smbpasswd to create a user account for samba and use this config file (modify the shared specification for your own use)

Samba config file created using SWAT

from localhost (

Date: 2000/01/22 08:49:00

Global parameters

loglevel = 0
workgroup = WORKSPACE
netbios name = neutrino
server string = neutrino
security = none
encrypt passwords = Yes
oplocks = no
veto oplock files = *.c *.h *Makefile *.cpp
share modes = no
dead time = 15
getwd cache = yes

path = /u/%U
read only = No
force create mode = 644
create mode = 644

path = /data
read only = No
force create mode = 644
create mode = 644

Thanks for the immediate response

Samba Version: samba-2.0.7-nto.tar

smb.conf file


  workgroup = WORKGROUP
  netbios name = QNX
  server string = R&D of Open Network Architecture Samba Server
  encrypt passwords = True
  security = share
  smb passwd file = /etc/smbpasswd
  log file = /var/log/samba/log.%m
  domain master = Yes
  local master = Yes
  preferred master = Yes
  os level = 65
  dns proxy = No
  name resolve order = lmhosts host bcast
  bind interfaces only = True
  interfaces = eth0      
  debug level = 1
  create mask = 0644
  directory mask = 0755
  level2 oplocks = True
  read raw = no
  write cache size = 262144

  comment = Home Directories
  browseable = no
  read only = no

  comment = Temporary File Space
  path = /tmp
  read only = No
  valid users = admin
  comment = QNX share
  path = /share
  public = yes
  readonly = no

I just tell the procedure what i have done:

  1. Windows pc is connected cross cabled with QNX machine
  2. Windows and QNX machine pings with each other and i can use telnet, ftp on it
  3. I compiled and installed samba-2.0.7-nto.tar in QNX and placed the smb.conf under /usr/local/samba/lib
  4. spawned /usr/local/samba/bin/smbd

smbd is not getting spawned i could not see any QNX directories in my windows machine.

note: fs-cifs worked for me and i could able to browse the windows directory from QNX, but unfortunately i want the other way round.

Thanks again

Depending how you compile it ( 2.07 is rather old, install 2.2.7 from the third party CD/Repository)

If it’s not getting spawn check in /var/log/smb.log or /usr/local/samba/var/smb.log why it refuses to start.

Thanks. With Samba2.2.7 i can able to spawn smbd, but still i could not access the QNX directory from windows, following are the events from log.smbd

[2008/09/29 19:35:47, 0] lib/interface.c:load_interfaces(216)
WARNING: no network interfaces found
[2008/09/29 19:35:47, 0] lib/util.c:set_maxfiles(1656)
set_maxfiles: setrlimit for RLIMIT_NOFILE for 10020 files failed with error Invalid argument
[2008/09/29 19:35:47, 0] smbd/server.c:main(751)
standard input is not a socket, assuming -D option

I have one basic doubt, Whether SAMBA will work for cross over cable???
since i have one windows pc connected with QNX machine thro cross cable…


The crossover cable doesn’t matter to Samba. That’s assuming of course that you can ping back and forth between the QNX and Windows machine. If you can do that, then you have connectivity and Samba will work.

The error messages look like you are starting Samba before your network is up and running. You might want to make sure the network interfaces are available before starting Samba.


I don’t think a crossover will work at 100Mbit, but it should at 10.

"WARNING: no network interfaces found " is kind of self explanatory don’t you think?

I have windows pc connected to a QNX machine thro cross cable, and i can ping the windows pc from the QNX and vice versa, and i can able to run the telnet and ftp services also
Only after that i spawned smbd

So can i assume all m network services are up and running at this point of time…?

I have a doubt, should run a nmbd too???
Because i tried to spawn but it did’nt
following were the error logs obtained

[2008/09/29 19:27:42, 0] nmbd/nmbd.c:main(794)
Netbios nameserver version 2.2.7 started.
Copyright Andrew Tridgell and the Samba Team 1994-2002
[2008/09/29 19:27:42, 1] lib/debug.c:debug_message(258)
INFO: Debug class all level = 1 (pid 125964321 from pid 125964321)
[2008/09/29 19:27:42, 0] nmbd/nmbd.c:main(826)
standard input is not a socket, assuming -D option
[2008/09/29 19:27:42, 0] lib/util_sock.c:open_socket_in(783)
open_socket_in(): setsockopt: SO_REUSEADDR = True on port 137 failed with error = Operation not supported
[2008/09/29 19:27:42, 0] lib/util_sock.c:open_socket_in(792)
open_socket_in(): setsockopt: SO_REUSEPORT = True on port 137 failed with error = Operation not supported
[2008/09/29 19:27:42, 0] lib/interface.c:load_interfaces(216)
WARNING: no network interfaces found
[2008/09/29 19:27:42, 0] nmbd/nmbd_subnetdb.c:create_subnets(239)
create_subnets: No local interfaces !
[2008/09/29 19:27:42, 0] nmbd/nmbd.c:main(872)
ERROR: Failed when creating subnet lists. Exiting.

Thanks in Advance

Oh I just realized you are running 6.2.0. Maybe it’s related . It’s very old.


You don’t need nmbd to just browse directories and copy/paste files since nmbd provides Windows Name Server functionality.

It’s still strange that nmbd is failing and smbd is not. By chance are you trying to run them as non-root? They are typically started as ‘smbd -D’ and ‘nmbd -D’ by root (in the rc.sysinit or rc.local file after the network starts).

With smbd running (I assume you have verified it is via pidin), are you able to browse the QNX box? If not, check the samba log files in /var/log/samba (you may need to create this directory for Samba to store it’s log files if you have not done so) as smbd will log info on connection attempts/failures.


Tim, the error messages the OP posted are from the log file to that part he got setup ok


Ah, OK. It’s been forever since I looked at the log files since I’ve had Samba successfully running for a long time now.

Looking in my ‘Using Samba’ book in the troubleshooting section they recommend to run the daemons from the command line with a very high level of debug turned on to see where they fail.

smbd -d 10 -i
nmbd -d 10 -i

I’m also curious about JK’s config file and why he specifically specifies the interface and IP address. You didn’t in your sample file and I don’t in mine either. I wonder if that’s causing the problem esp if en0 doesn’t have an ip address of


Just realize you specify the interface as eth0, under QNX6 it’s en0. Anyway as Tim mention don’t specify the interface and the bind interface option as well.

It Worked…
Thanks Tim and Mario
I removed the lines from smb.conf that you guys mentioned
re-installed QNX and it worked
Now i am able to browse my QNX directories with my windows pc.

But still nmbd is not getting spawned… but thats ok as far as SAMBA works

Thanks once again :smiley: