Network card not detected in QNX 6.3.2

Hi all

QNX Version : 6.3.2
System: IBM Lenova Think centre

Following is the NIC card details obtained thro the command
pci -vvv

Class = Network (Ethernet)
Vendor ID = 14e4h, Broadcom Corporation
Device ID = 167bh, NetXtreme BCM5755 Gigabit Ethernet PCI Express
PCI index = 0h
Class Codes = 020000h
Revision ID = 2h
Bus number = 3
Device number = 0
Function num = 0
Status Reg = 10h
Command Reg = 106h
I/O space access disabled
Memory space access enabled
Bus Master enabled
Special Cycle operations ignored
Memory Write and Invalidate disabled
Palette Snooping disabled
Parity Error Response disabled
Data/Address stepping disabled
SERR# driver enabled
Fast back-to-back transactions to different agents disabled
Header type = 0h Single-function
BIST = 0h Build-in-self-test not supported
Latency Timer = 0h
Cache Line Size= 8h un-cacheable
PCI Mem Address = d0100000h 64bit length 65536 enabled
Subsystem Vendor ID = 17aah
Subsystem ID = 100ch
Max Lat = 0ns
Min Gnt = 0ns
PCI Int Pin = INT A
Interrupt line = 11
CPU Interrupt = bh
Capabilities Pointer = 48h
Capability ID = 1h - Power Management
Capabilities = c003h - 64002108h
Capability ID = 3h - VPD
Capabilities = f4h - 7e1f9d76h
Capability ID = 9h - Vendor Specific
Capabilities = 78h - 2de779ffh
Capability ID = 5h - Message Signaled Interrupts
Capabilities = 80h - cbe67efch
Capability ID = 10h - PCI Express
Capabilities = 1h - 288fa0h

ifconfig en0
ifconfig: SIOCGIFFLAGS en0: No such device or address

ifconfig -a
lo0: flags=8009<UP,LOOPBACK,MULTICAST> mtu 33212
inet netmask 0xff000000

In my Network configure window i am not able to see my Devices tab…

any suggestions???
Has Anyone came across this scenario???


Provide vid, did to the driver:
io-net -dtigon3 vid=0x14e4,did=0x167b,pci=0 -ptcpip

Spawning io-net i was able to see the Devices tab in my network configure window, and i configures my IP and then spawned inetd

Now i tried to ping my windows pc which is cross cabled with that of my QNX
Initially it started to ping successfully but after a static time its timing out…

This is happening repeatedly… so that i could’t telnet my QNX pc from windows

any suggestions???

Thanks in Advance

Hello JK,
Please make sure you do not have unnecessary copies of io-net running.
In other words,
slay –f io-net
before typing
io-net -dtigon3 vid=0x14e4,did=0x167b,pci=0 –ptcpip

By the way, the idea behind typing this command is not to launch io-net as it is running already. It is rather to force detection of the network card.


Hello Yuriy
I tried that too its not working…

  1. Powered Up the QNX system
  2. Slay -f io-net
  3. io-net -dtigon3 vid=0x14e4,did=0x167b,pci=0 –ptcpip
  4. inetd &
  5. ifconfig en0 ipaddr

Then if i start the ping command its pinging only for few seconds after that
no host network not found is getting displayed


Make sure the system logger (slogger) is running.

Then post the output of the system logger (sloginfo). That might help figuring out why the card only performs for a few seconds before it stops.


Hello JK,
What happens if on your QNX box you ping its own IP address?
By the way, what is the purpose of installing QNX on IBM Lenovo Think centre? The easy way is to install VMware workstation on this computer and run QNX on a virtual machine.

Below are the logs i got during the process of slaying and running io-net and inetd from sloginfo, Is this a issue with the ethernet card?

devn-tigon3: unable to reset chip
devn-tigon3: PCI-Express card(a002)!
devn-tigon3: unable to reset chip
tcpip starting
using pseudo random generator. See “random” option

Yes i can ping to my own QNX ip addr
I have a limitation to use this pc

Thanks in Advance

Hello JK,
My suggestion was not to use a different PC. Use this one with Windows; install a virtual workstation (; run QNX on a virtual machine.
Are you going to use your PC as a development host or target computer?


hi yuriy
i am using the setup as a development host. In that i want the USB to be enabled so thats why i installed QNX6.3.2

FYI… i network card was not detected with QNX6.2.0 too

one more doubt - is there a way to auto detect the USB in QNX6.2.0 i tried io-usb but there was no driver in bin

Hi JK,

I am getting the same error when trying to setup the network on QNX632. I am using the same broadcom network card. Can you let me know if you got a fix from QNX for the same? or any luck with your issue?