pkgsrc help

I had a few minutes to try and play around with pkgsrc. So I went to the pkgsrc page on Foundry27,

I am COMPLETELY lost. I’ve bounced around the Foundry27 site. I’ve bounce around the NetBSD site. If the fate of the universe depended on me being able to say even one intelligent thing about pkgsrc we’re all goners.

My favorite line is “Download pkgsrc with QNX diffs.” There’s even a link, … pkgsrc/scm Under “HEAD” there’s directory called “pkgsrc”. Great! Except the only thing in it are more directories and some ReadMes. There is a “pkg_tools”, sub-directory, which sounds promising. Inside pkg_tools there are lots of things that start with “pkg” but none of them are “pkgsrc”. So what am I supposed to download? Surely I’m not supposed to download each individual file with an individual click.

Isn’t there a tarball somewhere? Is there not a binary called “pkgsrc” that I run, like I do with rpm? (Okay, okay, “pkg_add”. I can handle that. Where is it?)

Why do I have to get this from the Foundry27 site? Is NetBSD not willing to fold the QNX changes back into the main line?

Can some one please explain pkgsrc on QNX to me? Or at least point me in the right direction?

-James Ingraham


Here is where you want to start looking. [](

I suggest from this link you click on “bootstrap” and print off the page. Follow the step by step instructions.
Now let me tell you a few things I found useful after a couple of tries.

  1. If you download the whole tree, it takes a long time. In my case overnight. There are thousands of file that are downloaded. They are small so size is not the problem, but the volume mucks up your file system. If you like to search file files like this:

find / | grep myfile

Then you will be quite unhappy once this is all downloaded. In my case, I was able to use and mount a separate drive just for pkgsrc.

In the same vein, once you have the tree downloaded, you may want to look for something specific in the same way, as in :

find pkgsrc | grep someapp

I suggest that instead you just create file:

find pkgsrc >list

and thereafter grep on the list.

That’s the same link I posted that I said had me totally confused.

I followed the “bootstrap” instructions until I got to the linke I mentioned about “downloading pkgsrc with QNX diffs.” Download HOW, exactly?

Good stuff. If only I could get to the point where I could use that advice.

Incidentally, I did try to use Subversion to get the files. Of course, I had to manually get svn working, since I obviously can’t use pkgsrc. Catch-22 if I ever saw one. But I did get it. When I try to use svn to get the HEAD directory it doesn’t like my login. Which could be because I’m doing something wrong, something is getting blocked by a router / firewall somewhere, or because the line I copy-pasted from the Foundry27 page was a joke on newbies like me.

Thanks, though.

-James Ingraham

I assume that you tried this:

svn checkout --username

Well that’s the key. If it doesn’t like your login, that must be the problem. You could try creating a new login. I haven’t downloaded in a long time, so for all I know the problem is on QNX’s side.

Yes, although I don’t understand WHY I’m doing this. Or why Foundry27 doesn’t even MENTION how to get Subversion for QNX. I managed to get it on my own. Which also meant getting the Apache Portable Runtime. Fortunately I had figured out how to get APR and Subversion compiling on QNX some time ago. I wouldn’t have had time to figure them out this time around.

Incidentally, some may protest that Foundry27 DOES mention how to get Subversion, on the Bazaar at … 20Plug-ins Except there are two Subversion plug-ins for Eclipse. I DON’T HAVE ECLIPSE!

Again, WHY doesn’t it like my login? I can log in on the web site. When I try the svn line it asks me for my password. I type it. It asks me for my username. I type it. It asks me for my password. I type it. It hangs forever. (I’ll post the actual responses on Monday when I get back to work; I don’t have a QNX box at home.)

I’ll give that a shot.

I don’t think it’s an outage. There’s plenty of Subversion activity in the HEAD_640 branch.

Again, thanks for helping.

-James Ingraham

Maybe something is wrong with the version of svn you build.

The question is why use Subversion to get pkgsrc? Why doesn’t the tarball downloadable from the NetBSD pkgsrc website already HAVE the months-old QNX diffs? Or at least why doesn’t Foundry27 provide a tarball?

It’s not on my system. I’m guessing this is an SE / PE difference.

That’s very possible. In fact, I had an older version of svn already on my system, and it CLEARLY didn’t like that version. But since neither QSSL nor Foundry27 seem to offer any explanations I’m relying on help from here.

Here’s the actual results of me trying to use svn:

/root/pkgsrc ># svn checkout --username ingraham Authentication realm: <> Authorization Realm Password for 'ingraham': Authentication realm: <> Authorization Realm Username: ingraham
Here svn hangs until I hit Ctrl-C. Then it responds:
svn: OPTIONS of ‘’: authorization failed (
/root/pkgsrc >#

And here’s the Subversion version (that’s fun to say!) info:

[code]/root ># svn --version
svn, version 1.5.2 (r32768)
compiled Oct 3 2008, 16:13:09

Copyright (C) 2000-2008 CollabNet.
Subversion is open source software, see
This product includes software developed by CollabNet (http://www.Collab.Net/).

The following repository access (RA) modules are available:

  • ra_neon : Module for accessing a repository via WebDAV protocol using Neon.
    • handles ‘http’ scheme
  • ra_svn : Module for accessing a repository using the svn network protocol.
    • handles ‘svn’ scheme
  • ra_local : Module for accessing a repository on local disk.
    • handles ‘file’ scheme[/code]

James Ingraham

FWIW, none of our windows hosted PE machines with 6.3.2 installed had svn.

We downloaded the eclipse plugin.

Here’s the actual results of me trying to use svn:

[code]/root/pkgsrc ># svn checkout --username ingraham
Authentication realm: Authorization Realm
Password for ‘ingraham’:

You need the username used to create your myqnx account.
usually an email address. eg

svn co --username


Thanks! Except I got the exact same result.

I also tried creating a new account with a different e-mail address. Same thing.

-James Ingraham

Don’t know about Windows but it’s definitely part of the 6.3.2 self hosted.

Get Turtoise SVN for windows and try it from there. It has to be something wrong with your build.

Indeed. Tortoise SVN is downloading pkgsrc from Foundry27 as we speak. I’ll see what happens from there.

Of course, this just re-inforces my frustration. Maybe once I have pkgsrc working I’ll be able to get Subversion working in order to get pkgsrc working. :confused:

Thanks, everyone.

-James Ingraham

For those who are curious, the problem with Subversion on QNX turned out to be an old version of Neon, 0.26. Recompiling with Subversion with Neon 0.28 appears to have fixed the login problem.

And what’s Neon, you ask? Why, “neon is an HTTP and WebDAV client library, with a C interface.” Thanks for clearing that up.

-James Ingraham

I’d be Very surprise if stuff from pkgsrc can be build from Windows. That means you will have to copy it on a self-hosted machine which if it’s 6.3.2 already has svn :wink:

Even I’m not dumb enough to think I could.

Which I did.

Which I don’t, but sorta kinda vaguely do.

Which it doesn’t.