Using phpPGmyadmin

Hi all,
I want to gain access to my Postgresql database via Phppgmyadmin.

I have installed Apache together with PHP and the Postgresql database, but I can’t login.

Another program i use (written in C with embedded SQL) can access the DB without any problems, but via die phpmyadmin webinterface I can’t login.

Are there any hints what to do?
Apache and PHP works, the SQL Server is running…
Password and host (localhost) is the same that I use in this C program.


I know this won’t help much, but I had no problem with using Phpmyadmin with a MySQL database. I’m curious as to whether you compiled Postgresql yourself or used a pre-compiled version. I’ve had trouble getting the latest release to compile under pkgsrc.

I just used Apache, PHP and Postgre from the repository.

My OS is 6.3.2

Another thing i noticed: When I start postmaster, it normally produces tons of logs on the console (I saw this when using the fine working C program). But when I try to login from phppgadmin, it doesn’t say anything. Seems as if phppgadmin doesn’t even try to find the database…

Did you set the server of your DB in phppgadmin?
If you are not sure with connecting, sniff into your loopback device or ethernet device!
Depending on your Setup, do root@localhost (user@localhost) root@phppgadminhost (user@…) have Access?

Afaik there was also a flag in PhP which can prohibit connections to other network/servers being possible.

Yes, I’ve set hostname and port, also default-db and even extra_login_security to false.

Do you remember which flag that was? :slight_smile:

How do I sniff the loopback device? With tcpdump I can listen on en0, and wireshark isn’t available for QNX (afaik).

Solved: it seems as if the old PHP version delivered with QNX doesn’t support SSL-mode together with pg_connect; I commented the lines 668+669 in phpmyadmin/libraries/adodb/drivers/ and now it works :smiley: