6.4 experience

I was really hoping to upgrade our system here to 6.4 but quickly ran into several problems.

I coudn’t install 6.4 on a VMware machine because it couldn’t find graphic driver even though devg-vmware.so is available.
So I tried installing it on my target machine which is Advantech Single Board Computer with intel chipset using the i-830.so driver. This time it installed okay but when I try to use any photon app that uses offscreencontext drawing stuff it doesn’t draw it on the screen. This target machine works with 6.3.2 but not in 6.4. I am kind of disappointed with 6.4 installation but maybe a patch will be released soon :frowning:

I installed QNX 6.4 in VMWare and worked well with the same driver (devg-vmware.so) in 1024 xs 768 without struggling so much (It’s a Dell with an ATI FireGL V3100 display adapter).
I also had the problem you mention in my target machine (a Dell too) but it was solved changing driver to extreme2.
I found other problems with 6.4 that I am going to post in another topic to don’t interfere with your question.

Juan Manuel

VMware works fine for me in 6.4 (Using vmware 6.5).

devg-vmware.so only works if you are using a 32bit colour depth in your host OS (see the 640 release notes at qnx.com/developers/docs/6.4. … 6.4.0.html - It’s PR60669)

okay, I am running vmware 6.0.2 but the virtual machine that I ran was created from vmware version 5. Anyways, I created a new virtual machine with version 6 and it worked.

Now with regards to i-830 driver, has anyone tried running it with advantech SBC PCA-6187? Extream2 driver didn’t work for me.