ftpd error message


I try to configure an anonymous ftp server.

dr-xr-xr-x 5 ftp ftp 1024 Dec 13 16:07 ftp

Dec 13 16:39:04 nto ftpd[507943-1]: using conservative LOGIN_NAME_MAX value
Dec 13 16:39:04 nto ftpd[507943-1]: connection from kwp-wks-01 to robbie.klein.local
Dec 13 16:39:04 nto ftpd[507943-1]: can’t getcwd: No such file or directory
Dec 13 16:39:04 nto ftpd[507943-1]: ANONYMOUS FTP LOGIN FROM kwp-wks-01, IEUser@ (class: guest, type: GUEST)
Dec 13 16:40:07 nto ntpd[245794-1]: synchronized to, stratum 1

It is not possible to see the files in the ftp directory. Who is the owner and witch rights are correct?

Thank you for the help


Yes there has been a problem with ftp for some time. At first there was a work around which is probably still documented. You had to make a /usr/ftp/bin directory and put ls in it. You also needed a /usr/ftp/lib directory with a shared library copied to it. The last time I upgraded, I think to 6.3.2 it broke again. I think there was a bug in pipe. Someone at QSSL gave me a fixed version and now my anonymous ftp works fine.

What version are you using? I would think that 6.4 would have the fixes. If not you can send me an email and I will send all the related files, ftpd and pipe. maschoen@pobox.com.

One last comment, even if you have the right software, setting up anonymous ftp is finicky. How to do it is documented all over the web but make sure all the directories have the right ownership and permissions and that passwd and group are set up correctly.

Yes ‘pipe’ has not work well in same cases. I found SIGSEGV in pipe, for example with phrelay working. Is there a fixed pipe?

I received a fixed pipe a while ago that solved my problems. I don’t know if it was put into 6.4.

ls -l /sbin/pipe

-rwxr-xr-x 1 root root 23249 Aug 13 01:58 pipe

There are a few issues here. You’ll need the latest
chdir.c (lib/c) and ftpd from the networking project.


You need a lib directory and a shared library in the directory. This is documented on the QNX website.