problem about fdisk usb, HELP!!!

Hi all,

I’m a newbie of QNX. I just installed qnx two days ago.
I wanna make a bootable image into a usb flash drive,
and I’ve followed the instructions in

I pluged a usb flash drive into my qnx and run df,
I could see /dev/umass0 and it is mounted on /fs/usb0
and then do
fdisk /dev/umass0 delete all
fdisk /dev/umass0 add -s1 -t77 -p100
fdisk /dev/umass0 boot -s1
fdisk /dev/umass0 loader
mount -e /dev/umass0
So far, /dev/umass0t77 is supported to exist
However, I can’t see there is a umass0t77 in /dev.
Why? I think I’m right that I’m using umass0 but not hdX.
There two hdX in my system, hd0 and hd1, because I have two
hard disks in my computer. If hdX was right, it should’ve been
/dev/hd2, but I can’t find /dev/hd2.
Please help me… it drives me crazy!!!

Your usage of umass* is ok but I suspect the problem is that you are fooling around with a device while it’s still mounted.

First you should umount /fs/usb0, then you should umount all existing partitions: /dev/umass0t*. Then you can try your command sequence which looks ok to me.

Thx mario for your suggestion…
I pluged my usb flash drive after formating it as FAT32 on WindowXP.


/dev/umass0t11 /fs/usb0/

I did your suggestion…

umount /fs/usb0

umount /fs/umass0t11



ran my command sequence

fdisk /dev/umass0 delete all

fdisk /dev/umass0 add -s1 -t77 -p100

fdisk: slot is alreadyin use, use -f to force

An error occured. Then I ran “mount -e /dev/umass0” to re-fresh,
and ran “df”


/dev/umass0t11 /fs/usb0

fdisk /dev/umass0 show

The first partation’s OS name and type were still FAT32 and 11.
Although fdisk’s add command failed, delete succeeded…
Why did the first partation still exist???

It’s not : “fdisk /dev/umass0 delete all” it’s “fdisk /dev/umass0 delete -a”

I’ve just tried

fdisk /dev/umass0 delete -a

fdisk /dev/umass0 add -b -t77

mount -e /dev/umass0

However, /dev/umass0t77 still didn’t appear. I gave it up and directly did

dinit -h -f my_image.ifs /dev/umass0

fdisk /dev/umass0 show

The os name was NFTS… I don’t know why…
But… It was bootable…