Slow boot - Trying EIDE. Scanning for devices...

When the boot process loads my Compact Flash driver (devb-eide) I get the following message:

Trying EIDE. Scanning for devices…

This lasts for 1 minute and then says (… found 1 device).

The boot process continues successfully, but how do I make this scanning end sooner?

Tried several options, but this is my latest:

devb-eide eide noslave blk cache=2m,automount=hd0t79:/ &



You might want to look in the BIOS on your machine to see if there is anything there that might explain the delay. For example make sure the CF slot is a master and not a slave.

Your latest argument is the exact same one I use for our CF drives in the boot image (I assume you are executing this command in the boot image).

Also, what kind of CF card are you using (make and size).

It’s also entirely possible that you just have slow hardware (as in Motherboard). I’ve seen devb-eide take various amounts of time on different hardware using the same CF drive. But never anything as long as 1 minute.


P.S. There is also a newer devb-eide driver on foundry27 (I am assuming you are running 6.3) that might help if nothing else works (it helped me on a newer motherboard).

Thanks Tim and Happy Holidays!

I just got back to work today, so haven’t been able to try much yet, but have some info.
1.) I looked at the BIOS and didn’t see anything that would make the load slow.
2.) Yes, I am loading the driver via the boot image.
3.) I don’t think the CF matters now, because I tested a HDD and got the exact same 1 minute delay.

So, I will get the new driver (once I get all of the login info) and try that along with investigating more into the BIOS.

Thanks again,


If a harddrive also takes 1 minute to detect then I’d say you definitely need to get the newer devb-eide and try it. It specifically solved some of these issues.

Out of curiosity, is either the HD or CF connected via SATA or are they IDE? If either are SATA make sure to enable compatibility/legacy mode. Also if there is more than one IDE/SATA connector see if you can disable the other(s) in the BIOS so the driver doesn’t have to check those (or if you can’t, you can specify exactly which connector to use via arguments to devb-eide).


I’ve found that using diskboot in my boot image is causing the problem. When the driver is loaded it scans for IDE devices and finds an extra device, even though it says it only found one. If I don’t use diskboot, loading the IDE driver happens very quickly and only one device is mounted.

So, I’m not going to use diskboot…