I am trying to make an app like “helpviewer” in QNX.
So I took a PtWebClient and made it to display a the qnx help file (html) and I am not seeing all the graphics. It is almost working but not completely. My program is very very basic, the GUI only has a main window which has the PtWebClient widget. When the program executes it run a setup callback with following code:

PtArg_t args[2];

PtSetArg( &args[0], Pt_ARG_WEB_SERVER, “help”, 0 );

PtSetResources( ABW_Base_web_client, 1, args );

PtSetArg( &args[0], Pt_ARG_WEB_GET_URL ,“file:///usr/qnx630/target/qnx6/usr/help/product/photon/prog_guide/tutorls.html”, Pt_WEB_ACTION_DISPLAY );

PtSetResources( ABW_Base_web_client, 1, args );

PtSetResource( ABW_Base_web_client, Pt_ARG_WEB_OPTION, “50”, “iScrollbarSize” );

return( Pt_CONTINUE );

as you can see I am just trying to display tutorls.html file which comes with QNX, I am running 6.3.2

Furthermore, if I use “online” option instead of “help” it works fine. Using the “online” option uses the mozilla server instead of vserver, but the only problem with using the mozilla server is that I can not control the width of the scrollbar, so I would like to use vserver. Any idea? Is this got to do with image Image_Cache_Size_KB?

here is the content of my webservers file:

default server for “online” browsing (Voyager client by default uses this)

#online = vserver,VoyagerServer-2
#online = netfront,NetfrontServer
online = /opt/Mozilla/mozilla/ /opt/Mozilla/mozilla/mozserver,MozillaServer
offline = /usr/photon/bin/vserver.file -l -nVoyagerOffline,VoyagerOffline

default server for help browsing

help = vserver.file,VoyagerFile

Or is there a way I can change the width of the scrollbar when using the Mozilla server?