Installing Sealevel serial card


Has anyone had any success installing the SeaLevel 7804 8-port serial card (PCI)?

I followed the instructions supplied by SeaLevel which says to copy a couple of files from the installation cd to /etc/system/enum/devices and /sbin (sorry, i forget the actual names of the files). Then I changed the permissions on the file in /sbin to 775 as indicated.

After doing this and pysically installing the IO card, I boot QNX and it hangs after displaying the licensing information.

Any ideas?

p.s. I can dual boot into windows xp and the card is recognized and works fine.

I had to edit the configuration file for the enumerator because the device id didn’t match the one returned by the pci-bios. If you run pci -vvv, it lists all vendor and device id’s. Just look for the Sealevel card in there and then change your device id in the /etc/system/enum/devices/PCISERIAL file to match it. That is, if it’s the same issue.

Thanks for the suggestion. I was hopeful when I first read it. The only problem is that the system wont boot up when the card is installed. So I can’t get to a shell to try pci -vvv. If I take the card out and boot up, I can get to a shell, but then the card isnt there, so running pci -vvv doesn’t yield any relevant results.

With your problem, was the system hanging when you tried to boot up? Any other thoughts?


If the system is hanging with the card inserted and no QNX drivers started then you likely have some kind of hardware conflict on the PCI bus (sharing interrupts maybe with another device that can’t share interrupts). You might want to take a look in the BIOS and see if you see anything there that might explain the problem.

Are you sure you aren’t starting any drivers for this card (ie don’t start any serial drivers or any special drivers supplied with the board and see if that lets the pci -vvv command run).

It might also be that the Sealevel device is matching something else in the enum file (another device) and fooling QNX into thinking it’s another type of hardware. In that case you’d have to stop doing the device enumeration at boot time (temporarity comment out the enum-devices line in /etc/rc.d/rc.devices) and that may let you boot.


As it turns out, Elijuan was right.

I still couldnt figure out a way to get to a shell, but eventually I noticed that the BIOS was displaying a list of recognized devices (similar to what pci -vvv gives, just much more brief). The SeaLevel card was on there (as “Serial COMM Device”); I copied down the information provided, i.e., vendor id, device id, irq, etc. Then I removed the card and rebooted so I could check the enumeration file. Sure enough, the last device in the list (which happened to be mine) had the wrong device id. It was set to 7801 instead of 7804. After fixing this, everything worked fine.

Thanks for you help.

Andy :smiley:

The Sealevel COMM+2/EX provides the PC with 2 asynchronous serial ports … If you are installing a single port serial card select Ports (COM & LPT).

mcdst exams
mcitp exams