Installing QNX from ISO without burner

looking at other posts it seems I am not alone, i have the problem where I do not have a burner, I downloaded the iso and a program called Phantom CD, This created a virtual CD of the image which alowed me to run setup. This part was fine, it asked me to create a boot disk and I did.

The problem is upon reboot of the system, after the detection of EIDE devices I get the error ./diskroot is not found
unable to locate fs-pkg

It apears it cant find the CD drive containing the packages. How can I install QNX without a burner?

Is this still possible or am i doing something wrong perhaps.

I apreciate any help in this matter.

Thank You

I assume you are using a FaT32 partition right?
Is it a primary partition?

My primary active partition is a NTFS but I have a 5G FAT32 Partition waiting for QNX,

In the article you linked to, I am haveing problems with the instruction "So quit and open a Terminal. From within the terminal type…

How do I quit to a terminal?

I have tryed typeing after the point of the errors and I cant type anything. I do have a Microsoft Internet Keyboard Pro, Should that cause any problems. A previous install of an old version of qnx did not give me any problems with the keyboard except I never had to type at a terminal or console screen.

I apreciate your help, any sugestions?

Are you installing QNX 6.2.0 or 6.2.1 ?
That article is for QNX 6.2.0 (you can download qnxnc620.iso from ). If you want QNX 6.2.1, I suggest you first install 6.2.0 following that article, and then “upgrade” to 6.2.1 by first mounting the qnxnc621.iso under QNX (same trick as mentioned in the article).

Not sure which version I tryed, but I will try 6.2.0 as you said and I will get back to you.

Thanks for the sugestion.

I just tryed as you said and this time the error message reads “No QNX 6.1 or greater filesystems available to mount”

I think this would mean it dont like my active partition being NTFS. I apreciate all your help in this matter but if QNX is gona be this dificult then I don’t need it. Im gona try installing FreeBSD tonight, and when I get RedHat disk 2 reburned, I will Install that.

Thanks once again for all the help.

If you can get RedHat CD reburned, maybe you can get QNX CD burned too ? :slight_smile:

Seriously, I can understand your frustration, but remember we are trying to do something NOT officially supported by QNX. I am writing a article on installing QNX 6.2.1 without burning CD. It should be ready soon if you want to give it a try.

Now, back to your “adventure”, do you have more than one FAT partitions? If so, QNX has to be installed on the first FAT. Another question, when you tried QNX 6.2.0 and ran “setup” from phantom CD, did you see two options: 1) install QNX 2) make a boot floppy. You will have to do BOTH: first make the floppy, then do the install, finally reboot when prompted to do so. (The article by cdm was not clear on this but it is really mentioned if you read it carefully). When the PC is booted up from floppy, it should “see” the QNX installed on the FAT partition.

I will be buying a burner soon, in the next few weeks. Meanwhile I will give it a try again, I only did the creat boot disk, I did not do the first option to install because I understood it as it would write onto my active NTFS partition.

My partition setup is with two partitions. It is a 40G drive, the last 5G of the drive is formated as FAT32, the remaining space at the begining of the drive is a NTFS with Windows XP. Thus I only have the one FAT32 partition. When I retyred with 6.2.0, I placed the iso onto the FAT32 partition (non-active), created the boot disk and rebooted.

I am hopefull for this article you plan on writing and will give it a try, first tonight I will try doing the first option to install now that I have the boot disk. And eventualy when I get my burner I will burn that too.

My friend had been burning for me and when I did the media check in RedHat install, disk 2 failed. I avoid asking him to reburn as his burner is haveing problems and wastes alot of CD’s, buffer goes low.

I thank you for your patience and understanding.

aha, that’s the problem! you have to select the “install” option.
No, it will NOT write onto your NTFS. It will give you a choice and you should select the driver letter that corresponds your FAT partition.

btw, the article is already out