HELP! PLease... :)

I have a floppy disk with a file on it created from a QNX based console. Is there a way to open this file on a windows system?


Hello everyone BTW. :slight_smile:

Only if you run QNX inside VMWare. or any other Virtual Machine. If it`s QNX6 you can download an VMWare image from the QNX website. Once the file is on the VM you use TCP/IP to copy it on windows.

OK. I have VMPlayer on my lappy at home, so, I can download a version of QNX and run it on VM to open the file. Can I create a shared file on the VM and also in windows and transfer it that way? I have used Salamander File manager before to access UNIX files, is there no similar app for QNX?

Thanx for your help mate. :slight_smile:


QNX supports Samba so you can create a windows share using Samba.


Thanx Tim. I think the only thing with that is that it runs primarily on the QNX/UNIX system yes? The kit involved is medical instruments and although the instrument software operates over the QNX OS it does not allow any interaction with it. All I can use on the console is the instrument UI. Basically, we are getting new equipment from the same company, this too runs on QNX, the problem is the old kit is so old the QNX files it creates are not even usable on newer versions of QNX! (So we are told anyway) This means that all the configuration of the new instruments will need to be done manually. This is a BIG job and likely entails a member of staff sitting and inputting all the settings, ranges, STAT panels, result configs, ASSAY files etc by hand over maybe a week! Not to mention that in order to get that info they will have to screen dump 100’s of screens to a printer.

I can and have created a backup of the configuration on to a floppy disk, but as I said it is not compatible with the new instruments version of QNX so I was hoping to be able to view it and create a XL spreadsheet rather than printing out literally hundreds of pages.



Not sure what this is all about, but floppy format is the same between QNX4 and QNX6. However QNX6 doesn’t have vol anymore so that could indeed be a problem.

You could connect the DISK to the PC and give it direct access to the VM and get the files you want that way.

I think the problem you have is the responsibility of the system provide, they should/could provide an upgrade path.


Why don’t you just ftp the file from QNX to windows then?

If the QNX board in the instrument has an ethernet port on it you could temporarily connect an ethernet cable to it and to your laptop and ftp the backup file to your laptop.

Even if the QNX board lacks an ethernet port as long as you can get the file on a floppy disk you can take it to your VMWare machine (ie your laptop) and from there you most definitely can ftp the file from the VMWare QNX to Windows.

As Mario mentioned, there is no difference in file format between QNX4 and QNX6 assuming the backup file fits completely on 1 disk. So not sure why the company is telling you they aren’t compatible.


Thanx guys. I will try it.


Two things come to mind on this:

  1. Maybe the older system is Qnx2 and not Qnx4, so file format is different.
  2. It’s possible the file on the floppy contains binary configuration data.
    • If so you won’t be able to read it and make any sense out of it.

As Mario stated, the original manufacturer should provide you with a tool that will convert the old configuration data to something that is readable by the new machine.

I welcome all.

Has tried to establish QNX Neutrono RTOS 6.4.1 together with other OS on one hard disk. Installation has appeared quite clear and simple only has not come to the end why that was chosen with section of a disk has refused the loader has chosen item not active section (in general all three variants, and active and not active and Ñ‚) but at transition to a following stage all has ended has suggested to reload a computer and not that has not occured. At repeated attempt has shown that the chosen section has other name for QNX.
Prompt in what the reason. Installation QNX Neutrono RTOS 6.4.1 раÑ

Seems like this has gone through a russian->english translator ( very bad grammar but excellent spelling ;-) ) I can’t understand your post. Why don’t you try

I there (on was. Similar my first steps and not skilled questions (beginner) to whom that have not liked from moderators. And at attempt to receive a particulars has collided with aggression and insults. As I have understood there many with an operational experience in QNX, probably it is the reason of hostility to beginners. But to begin with what that it is necessary. I use the program the translator. It is Not enough forums about QNX therefore I here. I hope I shall not complicate the questions.
The big desire to establish QNX.

The problem in that that at a choice of all necessary items of installation system QNX, (together with other OS), QNX is not established and is simply reloaded. In what there can be a reason?

Is QNX loaded? If not, are there any error messages. If it loads, will it boot? If not, are there any error messages?

At me on the rigid 4 sections, one section for QNX, the others are borrowed by other OS. Installation QNX together with other OS, figure 1. For loading I use Acronis OS Selector on another not probably. That is native loader QNX is not necessary. At a choice of all necessary items of installation system QNX gives out the following:
«Mounting filesystems
Unable to access /dev/hd0t179
Partition installation aborted!
Please remove the installation media, ten reboot your machine.»
Figure 2.
On it loading is interrupted.
At installation other mistakes (preventions, messages) were not.
Note. At me the hard disk and the disk drive is connected SATA (interface) at loading a disk on the first screen there are lines with SATA. Probably that QNX SATA the interface is distinguished. Only at a choice of a hard disk has shown one hard disk with mark EIDE. And should be or this designation (connection) of the interface of a hard disk, that is previous (the old interface)?

I have two ideas. You may be having trouble accessing your SATA drive. The other possibility is that your Acronis OS Selector is not compatible. I think the first idea is the most likely but I don’t have any experience with SATA drives under QNX.

  1. It would be desirable to specify, SATA the interface it roughly speaking a way of connection (connection) of a hard disk and CD/DVD of the disk drive (media). We correctly each other understand?
    Logically, if QNX installation would not support SATA that would not occur as at me CD/DVD of the disk drive (media) the same with SATA the interface. Why has shown a hard disk with mark EIDE to me not clearly.
  2. Acronis OS Selector not and as it is the universal loader which it is established in Windows and it is capable to load set Unix Linux *BSD and QNX. Only as Acronis OS Selector the greater program also is established in Windows that loader Windows should work (to be, is alive). If to establish other loader that some of my operational systems cannot be loaded… Acronis OS Selector loads (without problems) Unix Linux *BSD and QNX without their loaders.
  3. I did not manage to establish QNX! There was a message:
    «Mounting filesystems
    Unable to access /dev/hd0t179
    Partition installation aborted!
    Please remove the installation media, ten reboot your machine.»
    In this line « Unable to access/dev/hd0t179 … » it is shown that the section for installation QNX is created formatted)!
    At repeated attempt of installation the section chosen by me for the first time is designated as section for QNX, that is formatted).
    Installation QNX has not occured.
    Very much I hope that translation (sense) is clear also we understand each other.

The translation is not clear. My previous message still seems useful. Sometimes the BIOS has an EIDE emulation mode for SATA, however in your case since you have other OS’s using the drive, I don’t think that it is a good idea.

If a problem only in SATA the interface that can be solved this problem at me there is an input (contact, a loop) for EIDE. It is necessary to buy only a hard disk with EIDE the interface. I will try to specify about the engine for OS. System QNX has not been established! It is not present on a hard disk! Installation is not has gone right, in it and a problem! As the reason for me is not clear.

SATA is supported only if it is a standard controller. If it some raid controller running in SATA mode QNX does not support that.

You can try AHCI mode if the BIOS supports it.

Good luck.