Usb application launching from configuration path

Hi All,

I have a requirement for detection/removal of USB device. So i created an application for insertion / removal of usb and modify the configuration path “mass” file at /etc/system/enum/devices/usb path. I have launched my application by calling
driver(application path/App. name)

Few lines of mass file is as follows,

device(usb, .class=$(USB_CLASS_MASS_STORAGE))
driver(devb-umass $(DISK_OPTS) $(UMASS_OPTS)",vid=0x$(ven),did=0x$(dev),busno=0x$(busno),devno=0x$(devno),iface=$(ifa
driver(/home/usb_application) // MY APPLICATION LAUNCHED

Once my application is launched a pulse msg send to other application for indication of usb attach. But i am able to use usb device there is no entry for usb inside /fs/ folder. Even i tried to use mount command to mount the usb drive but nothing has happened.
       Can anybody help me out, from where i can launch my usb application from configuration path to avoid any problem in view usb disk data. 
          If i removed driver(/home/usb_application) from mass file then usb disk loaded and worked properly.