QNX password

I noticed that QNX only checks for the first 8 characters in the password

eg. login name: Tom
Password: helloworld123

QNX only checks for first 8 charaters and allows the login
eg it checks only ‘hellowor’ and allows the login

Do anyone know the reason behind, or is there any settings that i have to change?

Thanks in Advance

To my knowledge you cannot change that. I don’t know the reason, my guess is it’s historic, from the QNX4 days.

Check -u option of login, not sure if that will make a difference

This behaviour was quite popular in old times…

I remember some older Linux Distribution did the same. While it is a security risk i think it was introduced for compatibility reasons. Not sure though compatible to what ^^