Problem printing to serial port with lpd

Hi all,

I want to print to a printer connected to the serial port. So this is how I set up the /etc/printcap file:


But when I print with:

lpr -Pimp1 filetoprint

File gets spooled, but the settings of the serial port change! -Like parity checking gets set to “odd”, and baud rate to “13” (!). Even if I change the printcap file to look like this:


Lpd keeps leaving /dev/ser1 in bad state. The spooled fiel print when I change the settings of the serial port correctly with:

stty baud=9600 par=none < /dev/ser1

Any clues on why is this happening? How to fix it?

Thank you!


Did you try echo “Hi world” > /dev/ser1 ?

Yeah, that works. I mean, the serial port is ok until lpd tries to use it

So, any more ideas???

Did you configure /etc/config/lpsrvr ?

No, using only lpd because printers are serial.

It’s a bug in QNX: … &view=next

Yes this is a bug in QNX 6.3.2 and below.

It has been fixed in 6.4.0:

I had a qnx rep raise a PR for me: PR55791 (search for 55791 at … ware_fixes).