compling and running python - subprocesses not working

when i run python 2.5 on qnx 6.4.0 and try to invoke a network service it crashes with the following error trace:

Traceback (most recent call last):
File “/usr/qnx640/host/qnx6/x86/usr/lib/python2.5/”, line 486, in __bootstrap_inner
File “/root/ros_svn/ros/bin/rosmake”, line 89, in run
(pkg, build_count, total_pkgs) = self.build_queue.get_valid_package()
File “/root/ros_svn/ros/bin/rosmake”, line 148, in get_valid_package
for d in self.dependency_tracker.get_deps(p):
File “/root/ros_svn/ros/bin/rosmake”, line 73, in get_deps
self.deps[package] = roslib.scriptutil.rospack_depends(package)
File “/root/ros_svn/ros/core/roslib/src/roslib/”, line 99, in rospack_depends
return rospackexec([‘deps’, pkg]).split()
File “/root/ros_svn/ros/core/roslib/src/roslib/”, line 80, in rospackexec
val = (subprocess.Popen([‘rospack’] + args, stdout=subprocess.PIPE).communicate()[0] or ‘’).strip()
File “/usr/qnx640/host/qnx6/x86/usr/lib/python2.5/”, line 594, in init
errread, errwrite)
File “/usr/qnx640/host/qnx6/x86/usr/lib/python2.5/”, line 1011, in _execute_child = os.fork()
OSError: [Errno 89] Function not implemented

i then tried to compile python 2.6.4 and realized during configuration that thread.h was not found (of which i think that it’s responsible for fork(), right?).

Does anybody has helpful comments on running python, especially functionality that is part of

Or is it just not implemented on qnx?

Can you post a test script. This is probably trying to fork()
after pthread_create() but there’s probably a way arounde it.


Since OP hasn’t provided the reproduction scenario, I’ll take over the thread (is it ok?).

Error output:

pip version is 1.3, of which codes are available in this branch on github:

I’m using QNX 6.5.0 SDP SP1

On python’s console, os.fork(), which I assume the source of the cause, behaves differently.

How can I avoid this error? Thank you!