Problems with FTP get

I am working with the Atmel AT91SAM9260 Board

I am able to transfer file to the server on the board using ’ PUT ’ command.

However ’ GET ’ command does not work.

500 Illegal PORT command rejected
150 Opening ASCII mode data connection for ’ ftptest.txt ’
226 Transfer complete

But actually when I see the file it is 0 Bytes.

or else I get 425 Cannot build data connection: Connection timed out
error when I attempt immediately after PUT file command.

I tried Binary mode, with Hash On and Debug

Tried many combinations of settings in the /etc files.

Can anyone imagine where the problem lies ?

Thanks for Your help.


There was a slight incompatibility between ftpd and libsocket
on 6.4.1. Try using ‘passive’ mode in the client or build
the latest ftpd from the networking project on the foundry.


I get the same response with the Passive mode.

I downloaded the latest Core Networking Project and has the ftpd folder under services.

Please can You guide how can i integrate the new ftpd into the existing environment ?


  • abhiash

This problem occurs because Internet Explorer 6.0 uses Passive FTP to download files from an FTP server that is configured so that it only has a limited number of available TCP ports. Passive FTP uses an arbitrary TCP port to connect to an FTP server and may not connect if the FTP server is configured to use a limited number of TCP ports.