6.4.1 and kvm/qemu


after accessing ext2/3-partitions does not work I tried QNX with kvm/qemu. The installation worked well but unfortunately the network interface seems not to work. QNX detects a network card but all attempts to get an IP per DHCP (what is supported by qemu) or to set a static IP did fail. qemu itself was started with the parameters “-net nic -net user” (what should be enough according to linux-kvm.org/page/Networking).

So any ideas what the problem could be or how I could get it working?

OK, after some time I tried again using QNX 6.5

Same parameters “-net nic -net user” that work well for any other OS running within qemu environment, QNX boots, detects the qemu-network card successfully. But: DHCP is not working although it is available and accessible on the host system. And assigning an static IP to en0 also does not help, I can’t reach any network components/IPs outside of my emulation.

Any Ideas what is missing within the configuration of my QNX environment?

Is it too complicated to configure DHCP? :unamused:

Better go to the beginners forum :mrgreen:

:laughing: :laughing: :laughing: :laughing: :laughing: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen: :mrgreen:

Oh, have you ever been at the beginners forum? It would definitely be a good place four you!

DHCP is running on the host machine but there I have the same problem: the QNX guest can’t see it and therefore it does not get an IP from DHCP server.