QNX IFS & installer run on Xenon but not on Jasper Fores

good evening fffolks:

we are currently trying to get QNX641 (intel.com/technology/archite … ro+nehalem) embedded processor from Intel primarily intended for Storage applications.

we have not been successful in getting the QNX Installer to RUN. however, the installer runs and installs with no problems on an older Intel Xenon (SuperMicro PDSM4).

we have tried running the QNX Installer using a CD in a USB DVD drive, from a USB Flash Key, and from a SATA hard drive. QNX type 179 & 79 partitions were used on the SATA hard drive. we also tried invoking the QNX Secondary installer from Linux GRUB. both the new QNX loader that works beyond 8.4 GB and the older one that cannot access beyond 8.4 GB were tried. no success.

in all cases, the QNX loader runs and starts loading the IFS file from .boot. on the type 179 partition, the loader even requests selecting one of the 4 IFS files: qnxsmpbase.ifs, qnxdmabase.ifs, qnxbase.ifs, and qnxbase.qfs. however, after the IFS is selected, system hangs. a series of periods (indicating BIOS INT13 reads?) is printed and then the system hangs. either the loader does not completes successfully or the IFS file has some problems that causes the system to hang.

oddly, the installers work flawlessly when running on a Xenon platform.

btw, installers of Windows Server 2003, Windows 7, and openSUSE all run with no problems.

i have tried to install openSUSE on a disk on another machine and then moved the hard drive to the JF machine. that worked as expected. however, when i installed QNX on the disk and moved it to the JF system, QNX would not load at all. again, i suspect, the IFS would not run.

does anyone know what could be wrong? how do you fix this problem? has anyone else had any success with QNX641 on the Jasper Forest? any help would be appreciated.

thank you for your time and help.

have a good evening,


{ Pietro Comino Ottawa kept Sea Monkeys (Harvey Comics) at work