Can't mount / (type io-net)


I’m using a QNX-system that is stripped down to it’s minimum. During the boot process I call

mount -T io-net -o host=myname. /lib/dll/

on an relatively early stage to mount this system in QNet.

That works well on a full system but fails here (error message “Can’t mount / (type io-net)”)

What could be the reason for this? The required files are available on the system…


Can you post your build file for the stripped down boot/system.

If I type in “mount -T io-net /lib/dll/” as a non-root user I get that same error message:

Can’t mount / (type io-net)

But then on the next line I get a ‘permission denied’ because I tried as a non-root user.

It seems that what you see is the standard error message if something goes wrong. Hence the reason I want to see your build file / boot process.


I had the exact same problem earlier…

Before you use the mount command to mount the network device, you must first start io-net. Your script should look something like this:

mount -T io-net…(driver info for en0)

io-net only has to be started once… then you can use as many mount commands as you want.

NOTE: if you plan to start any protocols such as tcp/ip, you should make sure to specify them with the io-net command… (io-net -ptcpip)

Hope this helps