USB Mouse Not detetected while Photon starts

Hi everyone,

I have got a Dell machine with Intel Core2Duo processor and the motherboard has no PS/2 slots in it. Only USB mouse and Keyboard is supported by the machine.

In such a PC whenever the Photon is about to start it is showing some error messages in the screen which are stated as below:-

hidd_report_attach failed(5)
Cannot attach mouse input report (error code 2).

I am no longer able to booting into my QNX 6.3.0. Kindly help me with your valuable suggestions on this. Another person has already reported such error in Foundry 27 post of QNX and there is no reply from QNX people. Pls help me.


I don’t know how to solve the problem in QNX 6.3.0. I’ve had no trouble with USB mice and keyboards under QNX 6.4.1.


I’ve never had this problem under 6.3.0 SP2 or SP3.

I suspect it may be a BIOS option because QNX doesn’t normally have problems with USB hid devices. What BIOS options are there for USB and in particular USB keyboards/mice (sometimes in the BIOS those have extra options).


Hi Tim,

I am using Dell Optiplex 380 machine. I checked the bios and in the USB controller option it is in the enabled mode. There are 3 options in the USB controller section
3.No boot
I checked booting with all the options one by one. Still QNX is not booting. Also i think there is no problem with the USB controller because i am using USB keyboard and that is well detected while booting. Problem lies in the USB mouse only.

Can anyone give more input to this query so that i can find a apt machine for my projects. Currently i thot a High end Machine from Dell is the Best but it is causing such problems.


What kind of USB mouse are you using? Are you using any kind of KVM?

Have you tried unplugging the mouse during boot time and then plugging it in after QNX finishes booting? It’s a pain I know, but it might at least let you boot.

Assuming the keyboard is detected under QNX you should be able to figure out what’s going on with the mouse once you get QNX booting again.


Hi Tim,
I am using the Dell’s mouse only. My whole Dell Optiplex 380 machine has Intel Quar 2 Duo processor and has Dell USB Keyboard and Mouse. Regarding the unplugging of mouse, i have tried that at first when i saw such an error coming out. But the effect is the same. QNX is not booting with photon. Everytime the photon starts it’s causing the error no matter if your mouse is plugged or not.

I read ur previous posts regarding your problem of QNX using USB keyboard and mouse in the post

I think your problem was that QNX booted with photon but it was not detecting your mouse and keyboard. Also i read about your solution of editing the rclocal file and ph script.

I would like to ask another solution idea for my problem. Can i use the Live DVD of the QNX and then mount the HDD with the installed QNX in it. Then edit the files in that HDD filesystem and then boot with no photon? Can u suggest any other method?


Yes, you can boot from DVD and then edit files on the hard drive. You’ll have to manually mount the harddrive.

That thread you referenced is 5 years old now. QNX’s USB support is vastly better in the new versions than it was back then. I haven’t had a problem with USB mice/keyboards in a couple of years now. In any case, if you can’t boot regardless of whether the mouse is plugged in then it’s not a USB mouse issue.

If Photon is not booting but QNX is then I wonder if the real problem is the graphics driver and not the mouse. When you say Photon doesn’t boot do you mean it never displays the initial Photon login screen or that the login screen appears but the mouse doesn’t function?


Hi Tim,

I was on a holiday for some days now back to action.

I went on with my idea of using the live DVD of QNX but it failed because the photon of live DVD is not even working in this machine. When i say Photon is not booting means i can’t see the initial photon display login screen. Since you told that it might be a graphics driver problem i will now test the same DVD in other Dell Optiplex machine and tell you the result


Hi Tim,

I tried ur good old method. Now my QNX with Photon is booting and i am able to use the USB mouse and Keyboard. But the problem doesn’t end there.

Now i am not able to get a network connection. The onboard network card is not enumerated by the device. So my machine is not getting network connectivity. Also when i clicked the display options to adjust my screen resolution, it went to the black screen and said its opening the dekstop manager and the machine stuck.

So are the drivers available with QNX 6.4.1 old and doesn’t support Dell Machines??
Will these problems be solved if i download and install service packs?

pls do reply


6.4.1 is the newest version of QNX. So it would definitely support Dell machines if any version of QNX does.

But you said in your first post you were running QNX 6.3.0?

You can go to QNX’s website and see exactly what ethernet cards are supported under which versions of QNX (6.4, 6.3.2, 6.3.0 etc). Then you can check against the hardware in your machine.


Almost any video card that supports VESA will work, however some nice accelerations may not be missing, especially Photon text scrolling.

Hi everyone,

My issue regarding solving the usb not detecting in dell pc is now solved. I used QNX 6.4.1 RTOS and i installed it my pc. Then i followed the earlier links and removed the hard disk, fixed the HDD in a PC having PS/2 port, edited the config files and booted into QNX. Now i again fixed back this HDD in my dell pc. QNX booted. Now the problem was with network. I used a realtec network card and solved that issue also. Thanks to Tim for the support.

I still doubt why can’t QNX 6.4.0 or 6.4.1 RTOS support PC without PS/2 ports. QNX people has to do something about this.


The QNX 6.3.0 family and 6.4.0 family both support PC’s without PS/2 ports.

We use PC’s that only have USB ports and the keyboard/mice work fine on those. There is something different about the BIOS or motherboard in the Dell machine you have that isn’t letting it work. It may just be some setting you aren’t aware of.