QNX4 in Windows 7 virtual pc?

I have been using Qnx4 in virtual pc under XP for some time now.

I tried to install it under windows 7 virtual pc, but the network does not work.

Has anyone else tried this?



I have been having the same problem. Yours is the only other post I’ve been able to find on the subject. I am using 64-bit Windows 7 and Virtual PC. QNX4 installs and runs just fine. I have disabled Windows Firewall on the host and chosen the right virtual pc network adaptor. But the virutal QNX can only ping itself and not the host nor any other machine on the same LAN subnet. I’m using the default driver: Net.tulip -c21140 -I0 -l1 &, which worked fine under Windows XP.

I hope someone finds/has a solution to this.


Yes. Windows 7 Home Premium + virtual QNX 4.25 running on VMWare Player 3.1.3
Highly desireable to file share between Guest (QNX 4.25) and Host (Windows 7).

VMWare Player setup:
Virtual Machine–>Settings–>Network Adapter set to ‘NAT’ (used to share the host’s IP address).
Then Host can ping Guest, and Guest can ping Host.

Tried several things to file share, but so far no success.

  1. ftp from Host to Guest.
    when running “ls” command, Windows ftp client reports “Can’t build data connection”
    while ftpd running in QNX reports, “getpeername (ftpd) Function not implemented.”
  2. ftp from Guest to Host.
    “ls” and “get file” works, but “put file” results in “550 Permission denied”.
  3. Samba to access shared directory on Host.
    Setup Windows 7 by sharing C:\shared\dir\ (owned by “qnxuser” account)
    Also allow File and Printer sharing in Firewall setup.
    Then in virtual QNX:
    SMBfsys &
    user_smb qnxuser qnxuserpass
    mount_smb -mu -s -uqnxuser //WIN7HOST:192.168.XXX.YYY/shared/dir /mnt/local qnxuserpass
    results in Mount failed: Permission denied.
    also tried:
    mount_smb -mu -s -uqnxuser //WIN7HOST:192.168.197.XXX.YYY/c$/shared/dir /mnt/local qnxuserpass
    with same result.

Other methods of file sharing (not yet tried):
Using Samba in QNX to share a directory, making it accessible to Windows networking.

192.168.XXX.YYY is IP of Windows 7 host
192.168.XXX.ZZZ is IP of virtual QNX guest
host computer is dell inspiron 17 laptop

Further details on setup of virtual QNX…
contents of /etc/netstart:

export SOCK=$HOST
Net &
Net.ether2100 -I0 -l1 -v&
netmap -f
sleep 3
Socket $SOCK &
ifconfig en1 $HOST up
ifconfig lo localhost up
dhcp.client -d -i en1 &

Other things I have tried to achieve file sharing:

  1. Run /etc/nfsstart
    where ‘nfsstart’ contains:
    /usr/ucb mountd -n

    and /etc/exports contains: /home/qnxuser

    Then from windows, try to access virtual qnx:
    net use \192.168.XXX.ZZZ
    results in:
    System error 53 has occurred.
    The network path was not found.
    (yet, ping 192.168.XXX.ZZZ works fine.)

  2. mount_nfs [-rvw] rhost:/path mount_point
    mount_nfs -vw 192.168.XXX.YYY:/shared/dir /mnt/local
    appears to work (no errors) but /mnt/local does not exist.

  3. run: /usr/local/samba/bin/smbd &
    Then from Windows: net use \192.168.XXX.ZZZ as before
    (or enter file:\192.168.XXX.ZZZ into address field of Windows Explorer)
    results in prompt for user name and password.
    Entering ‘qnxuser’ and ‘qnxuserpass’ (identical accounts on Windows 7 and virtual QNX)
    results in Logon failure: unknown user name or bad password.

Contents of /etc/smb.conf:

workgroup =
netbios name = qnxuser
server string = Samba 2.0.6 (QNX 4.25)
security = user
encrypt passwords = yes
password server = *
log level = 0
create mask = 0644
interfaces = 192.168.XXX.ZZZ/255
browseable = yes
local master = yes
remote announce = 192.168.XXX.255

path = /home/qnxuser
writeable = yes
browseable = yes

path = /dev/cd0

The real answer, is making this work for Windows 7 will require $ for a 3rd party solution that would present a QNX-friendly NFS interface.

Probably because SMBfsys is old, and Windows 7 is new, and M$ likes to “embrace and extend” instead of ensuring backward compatibility. In the XP case, I cannot say because I only tried Windows 7.

Our company uses QNX as the backbone for our units. I’m running a QNX virtual server using Virtual PC 2007 on a Windows 7 x64 machine. I don’t know if this will work for you, but this is what works for me.
You need to set up a static route to the virtual machine on the windows 7 machine. To do that enter the following command in a command prompt with admin rights…
netsh interface ipv4 add neighbors “Virtual Adapter” 00-03-ff-6a-16-97
where the “Virtual Adapter” is the friendly name of the loopback adapter. The ip address is the ip of the virtual machine. the last numbers in the line are the MAC address of the virtual machine network adapter.
hope this helps.