QNX 6.3.2 RTOS


we are having QNX 6.3.2, the issue is, we are looking for new hardware for that OS.

Dell PowerEdge 840 is fine, but it’s discontinued and out of stock

i tried Dell PowerEdge R210, i think the issue is with the USB Keyboard

while booting, it detects the HDD, but on USB keyboard, it says : Error Sending to Device, it continue booting and give me the F1 option for installation but the thing is the keyboard is hanged and i can’t press F1

i’ve tried Connecting it to another computer with Serial Console, enabled Serial Console Redirection, everything i can control until the QNX booting process finishes .altboot… (i think when QNX initializes the hardware) i can’t send any ASCII code.

QNX 6.5 boots fine on the server, but the license we have is for 6.3.2

any hint ? :unamused:

Try looking in the BIOS to see if there is an option to active USB keyboard emulation.

thanks mario for the reply

please note there is no such an option

It sounds to me like there is a BIOS option to wait for F1 when there is an error.
In your case, the error is that there is no PS2 keyboard.
So the trick would be to get a PS2 keyboard, use it to modify the BIOS and
then remove it and use your USB keyboard.

A BIOS that doesn’t support a USB keyboard on boot doesn’t sound very modern.
I had an issue with a Dell Server booting related to the size of the boot file.
The problem was resolved by building a custom boot file without all the
un-needed disk drivers.

@mario thanks for the replay, there is no USB keyboard emulation in the bios


the QNX 6.3.2 which is having a problem with the USB Keyboard once it starts booting, not the Bios, i was able to use the USB Keyboard normally during bios booting / other OS bootings

the thing is, this server and all modern server doesn’t come with a PS2 Ports,

any hint ?

would a old keyboard work on a serial port ? will the QNX once it starts accept a or initializes serial port to receive commands from ?

If you have an old serial port mouse, yes it should work.

If QNX 6.3.2 isn’t working, you might want to try downloading the QNX 6.5 boot disk and trying that. If it also doesn’t work, then you are probably dealing with unsupported hardware. It would be hards to believe given how compatible most USB things are, but possible.

booting from QNX 6.5 is fine, i’ve also tried to edit the CD with magic iso such that the boot image will be 6.5 that detects the hardware, and the installation file to be 6.3.2, but it didn’t work, as if i change the boot image to 6.5, it will ask for the 6.5 License which we don’t have…


I wonder if this server is all USB 3 and that causes QNX 6.3.2 some issues. If you look in the BIOS is there any options for legacy USB support or a way to change the type of USB the BIOS emulates?

Assuming none of the above works, there is something else you can try which isn’t going to be trivial. Install a 6.5 NC version (I assume there is still an NC version of 6.5) of QNX, get networking running and then blow away the entire 6.5 by copying from a 6.3.2 machine over the network (it will be a bit tricky when you copy over the /bin, /usr/bin directories. Typically you need a RAM disk and copy /bin and /usr/bin in the RAM and set the path to them there). This assumes you have a custom 6.3.2 boot image that isn’t using USB since that would likely just result in you being right back to the same problem you have when trying to install 6.3.2.


dear Tim

thanks for your reply and concern

the usb of the Server is USB 2.0

would you please explain in more details the mechanism of your way ? shall i install QNX 6.5 or just boot from CD ? what is the NC version ?


This won’t help with the installation CD, but if you have a custom build script, try changing “[virtual=x86,bios +compress]” to “[virtual=x86,bios-nokbd +compress]” and deploy the result.

dear denkelly

am a QNX n00b,

if i have a machine already running QNX 6.3.2, how i can build an iso, with the option you specified, will it be beneficial with the R210 case ?

ok, so i did a little dig,

  1. shall i do the changes in qnxbootdma.ifs or qnxbaseboot.ifs ?

  2. by saying script you were saying that i am automating the Installation process by a script ?

thanks in advaces…

ok, so i cant edit the qnxbase.ifs and qnxbasedma.ifs

but the USB is not being detected and causing the problem because of the instflop.dat (the booting image):

  1. how i can edit the instflop.dat ?

  2. if i can’t, i’ve changed qnxbase and qnxbasedma with bios_nokbd option, but it didn’t take any effect, why ?


Here’s what I suggest you do.

  1. Install 6.3.2 on a machine. I assume you may already have this someplace.
  2. Remove the Harddrive containing 6.3.2 and put it in your Dell Server as the primary HD. Make the HD in the server the secondary Harddrive.
  3. Boot 6.3.2 on the Server from your HD.
  4. Initialize the HD that came with the server for a QNX filesystem. (fdisk and dinit are the commands you need).
  5. Then copy your entire 6.3.2 disk onto the new disk.
  6. Remove the 6.3.2 HD and put it back in the original machine. Make the HD that came with the server as the primary drive again.

With luck you’ll be booting.


@ Tim

step 3 is impossible,

system will hang during booting…