software for QNX6.3 does not work correct with 6.5.0


I have a strange problem with software for interrupt handling on CPCI-1500-I/O board from Addi-Data.This board contains a Zilog Z8536 chip and the software is for initialisation of this chip and interpretation of interrupts. Originally the software was written for QNX6.3 and worked well.
Now we upgraded our IPCs to QNX6.5.0 and our software for Z8536 does not work as expected. On the first PCI-slot I don’t get any interrupts from the I/O board anymore. (on other slots, the I/O boards do generate interrupts.) If I use a HDD with QNX6.3 on the same IPC, the I/O board on PCI-slot 1 generates interrupts as expected. So it seems to be no hardware problem, but a QNX problem. My first idea was, that it is a matter of APIC. I tried to use QNX6.5 with APIC support, switched off APIC in IPC-BIOS, … no success.

Does anyone has an idea, what the problem could be? Is it possible, that initialisation of PCI boards differs from QNX6.3 to QNX6.5?

thanks and regards