6.2.1 Fresh install on NS Geode board: Installer dies...

Hi everyone,

I’ve got an Arcom MediaGX board here with the Nat Semi Geode chipset on it,
and tried installing QNX 6.2.1 NC on it.

Installation is fine, detects video ok, network works ok( Voyager can browse web ),
but the package installer either dies when I try to install anything, or it lets
me select packages to install, but none of the buttons are ever enabled
( i.e. the “Install” button is always ghosted, even when I’ve selected some packages )

Anyone have any ideas?

The board has a 300 MHz Geode CPU, 32 Megs RAM

Do I need more RAM?

Also, will I be able to use mkifs in 6.2.1 NC, or do I need to try to get
my old 6.1 RTP CD to install ( hangs during boot )



Open a pterm and run ‘pidin in’ which will show how much free memory you have. Although 32 meg isn’t a lot in these days, I don’t think that is the issue.

mkifs is not available in the NC releases, so you won’t find it in your 6.2.1 release.

It sounds like you are trying to install a development system on a target system. You would do better to install QNX on your desktop and then only put the pieces you want on the target.

Thanks Rick, I’ve just tried what you suggested:

“pidin in” reports there’s 6.8 megs free when the installer
is still loaded, and 11 megs when it’s not.
So I guess memory isn’t the issue.

Would it help to copy the repositories from the CD
onto the harddisk, and then try installing from there?



I have to ask this. Did you really finish the install? When you are installing, it reboots, then continues when you login as root. Did it successfully finish the second half of the install?

If not, that may be part of the problem. Login as root and see what happens. I have certainly installed onto a geode based sbc without any problems.

Aha… this is where my original post was a bit unclear, sorry.

No, it didn’t do the 2nd half of the install properly.
That’s the part where the installer either won’t
enable buttons, or it just dies.



Ok, I’ve done some more playing
( and a heck of a lot of downloading of ISO’s ! ) :open_mouth:
and have found some interesting things…

RTP 6.0 and 6.1 both fail at the first hurdle:

pci-bios can’t find the BIOS!

so they’re out for this board anyway.

6.2.0 installs, but hangs if I use
the regular .boot file, DMA kills it.
.altboot works, and right now the
package installer is installing heaps of things!

So, it looks like I have a combination of things
that will work on this board…


I gather makeifs is not included!

Is there any other way to get around diskboot,
as it’s horribly slow for an embedded PC
Free solutions would be best, since this is a
personal project ( i.e. budget = $0 ) :smiley:



rumor says the upcoming 6.3 will re-introduce mkifs for the NC version. keep your finger crossed :slight_smile:
or, if you can’t wait, you can nicely ask rick (or other commercial QNX users) to make a customized boot for you ;)