Audi HDD

I’m sorry if it is totally dump question, but I’m simply a newbe to QNX.
I have 2.5" HDD taken out from Audi and I need to read its content. Thing is that any it partitions just won’t mount. I tried both Linux built in QNX4 and QNX4FS from with no luck. Fdisk reports first 3 partitions as QNX4.x, but when I am trying to mount them I get errors like (I cant remember it exactly now) “no root folder” and something with boot block?
Would anyone here know by any chance if Audi is using some proprietary QNX FS? Or is it just some how protected against reading the content?
I someone could give me a hint on how to get this working I would be so much appreciative.

Thank you

If you have a QNX system HD with spatch, and compare it with your disk, you might learn something.

If I were them, here is what I’d do. I’d build encryption into the driver. That could scramble the data and/or the positions of the data in a sector. The simplest way to do this would be to have 512 bytes of random data as a key that you XOR onto each sector. If you search the outer reaches of the drive and you find duplicate sectors, but no all zeros, you might have come across the key. Of course they might have done something more sophisticated.

Thats def a starting point.


Have you tried chkfsys? May be as simple as a corrupt filesystem which refuses to mount.

@maschoen: Thank you. Thats def a starting point. BTW would you by any chance also know what remaining 3 (except) partitions (unknown) are?
@denkelly: I doubt its a corrupted as it works in MMI…


After reading your original post again carefully, I discovered that you are not using QNX, but instead Linux with a QNX 4 file system.

That suggests one more obvious possibility. There is a completely new file system that comes with QNX 6. I know this is confusing, but maybe this will help.

QNX 4 (OS) - QNX 4 file system

QNX 6 (OS) - QNX 4 file system or QNX 6 file system

It is unlikely that there is a Linux driver for the QNX 6 file system.

So your best bet would be to get a QNX 6 OS and see if it can read the drive.

Its not confusing at all but thank you :slight_smile:
How new is QNX6? As far as I know those HDDs have been put there since 2007…

I don’t know for sure, but I don’t think the QNX6 FS was around in 2007.

Please have you mounted the audi HD?
Can you help me? I’m trying to mount also…
Thank yoi


Good luck on this.   Did you notice that the last post before yours was 9 years ago?

It was in 2011 - not 9 years ago - but I know what you mean, you read the date when the user registered. Happens to me once in a while aswell :slight_smile:

Oppse, yes. Shows how bad my memory is these days.

for bmw cic same problem