Lib fftw installation

I really need some help here.

Im trying to deploy fftw library on qnx 6.4.1 box. Its not that easy however (Im rather new to qnx). I have found fftw for qnx ([ ... EADME.html]( its in *tgz. When unpacked, there is a bunch of scripts, *h file, and library files (*so, *a). Trying to run +INSTALL script, but it returns “shift: nothing to shift”

Ive also tried to compile the source. ./configure script fails (returns config.status: error: cannot find input file: doc/FAQ/`).

Am I doing it wrong?

Ok, I have solved it. The problem was in fact, that qnx changed folder names to small letters.

I still need some help, however. Ive installed fftw on qnx box, but for programming purposes Im using momentics on windows box. Well, now my question is: fftw shoul be installed on (qnx box, as it is) or on windows box? In first case how to show momentics where are *h, and lib files?


The executable belongs on the QNX box.

Since you are using Momentics in Windows, the .h, .c, .cpp, lib files etc all belong on Windows (assuming you are going to compile it in Momentics). If it’s already compiled (ie came with an executable) and ready to run and you don’t need to compile then it doesn’t matter where the .h, .c, .cpp etc files are.


Dear Wallace

I know it’s been 4 years since this thread was last replied. I wanted to ask you if you could be more specific on how you solved the shift: nothing to shift in the +INSTALL script for FFTW?

Hoping you remember