Unable to Install QNX Neutrino on Advanced Format HDD

Trying to install Nuetrino SDP v6.5 on Advanced Format (AF -4K sector drive) but installation aborts unsuccessfully.
Screen displays “Can’t locate PnP Nodes” after initially displaying SDP 6.5 title,
then searches for USB, IDE devices etc., goes through partition selection but installation aborts on final stage of insalling files onto hard drive, with error “Unable to access dev/hd0”
Any help with this would be more than welcome, thanks

Can’t located Pnp Nodes is suspicious. Is Plug and Play enabled in the bios.

I don’t have any experience with AF sorry.

Thanks Mario,
The problem appears to be two-fold.
Firstly regarding the error prompt “Can’t locate PnP Nodes” after the “Booting QNX SDP…” prompt appears, this causes the USB keyboard and mouse to be non-functional. However a PS2 keyboard and mouse works fine. There is no Plug and Play listing in the BIOS menu.
Secondly regarding the “Unable to access /dev/hd0” prompt, at the final stages of installation (ie. "Mounting Filesystems…),
occurs with an Advanced Format SATA drive only. When fitted with a non-AF drive (512byte sector), Neutrino installs successfully.

I don’t believe this is directly related to the type of the hard drive. Or have you tried a “non Advanced Format” HD on the same machine? I bet it also fails, I guess the hard drive controller is not detected by devb-ahci or something like that.

Thanks Thunderblade, yes have tried non-AF(512byte sector) drive in same machine and Neutrino installs without any issues. I have also tried installing Nuetrino on several other machines with AF drives, and all fail with same results. Has anyone successfully installed Neutrino on an Advanced Format drive?

I think the bottom line is that QNX (to the best of my knowledge) does not really support the AF type drives. However, in fairness you are the first case that I’ve heard that couldn’t load the kernel. We are using 6.3 SP2 and see system timeouts under certain conditions of heavy disk activity with the AF drives. I have tried aligning the 512 byte sector boundaries with the new AF 4KB boundaries, but that did not solve our issues. I believe that I read someplace where QNX 6.5 had other issues with drives 2TB and larger. What size AF drive are you trying to install? I’ll be keeping a watchful eye on your success in hopes that I can glean something from it. Good luck!

Sounds pretty serious. I suggest you contact QNX support for this. I would have expected that no special support from the software side would be necessary but apparently it is.