Adding photon to buildfile in qnx 6.5

Hello all,
I am working with build file on qnx 6.5.0 where i am able to sucessfully build the image file without photon component but when i add the photon component (photon path,env variables ,shared objects,dlls) in the image file the image file does not boot and gets stuck up at the loading ifs… .
Can anyone suggest some solution.

It is very likely your ifs has exceeded the default size assumed by the loader. If the size of the ifs exceeds 3M less 64K, then you should change “Image Address” from “Default” (0x400000) to something larger. For example, 0x800000 will enable a (nearly) 7M ifs.

It is also possible that there is a limitation built into your BIOS. I ran into this problem when I upgraded a Dell Server from QNX 6.3 to 6.32. The installation CD boot failed the way you described. I was able to build a custom boot file without all the drivers on the installation CD and it then worked.

Thanks denkelly and maschoen,

My prob was memory i have defined the memory as 8m and it worked.

But i am stuck with an interesting problem?

I have created a build file (qnx 6.5.0 and x86 platform)with required libs,shared libs,dll and i am able to run the c binaries in the image file but when i run the GUI binary the code is being executed(i am able to see all the debug messages) but not able to see the GUI screens which i have developed in Photon app builder.

I have been debugging but not able to find the solution.

Please suggest me a solution?


I guess you mean that you are seeing text messages. So your video screen is still in text mode.
So it never went into graphics mode.
This is a configuration problem in your build file.
You might want to post it.

I’ve always found this a very tricky area.
You install QNX development and it works.
But it can be difficult to reproduced this on a target machine.
The documentation is there, but it’s scattered around.

I solved the problem, problem was with the io-display,once i gave correct vendor id ,deviceid it worked.